Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2475

GetNodes() sometimes returns no results, incorrectly.

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.0.0
    • 3.0.1
    • library
    • localhost
    • 1

    Description

      When run against a single node running on localhost, any attempt to run QueryAsync results in "Couchbase.ServiceNotAvailableException : Service n1ql not available".

       

      In ClusterContext.cs around line 252:

      foreach (var nodeAdapter in GlobalConfig.GetNodes())
      
      

      GlobalConfig.GetNodes() returns no results, resulting in node.NodesAdapter remaining null, resulting in node.HasQuery returning false.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            This appears to be a regression caused by the fix to NCBC-2422.

            richard.ponton Richard Ponton added a comment - This appears to be a regression caused by the fix to  NCBC-2422 .

            People

              richard.ponton Richard Ponton
              richard.ponton Richard Ponton
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty