Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2671

KV Throughput drop after failover-rebalance

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Cannot Reproduce
    • None
    • 3.0.6
    • None
    • 1

    Description

      Running situ test against the 3.0.6 RC (SHA: d083fe850b50728afdcc221bcb13758cd5044592).

      Getting a significant drop in throughput after a failover of the 'master' node and rebalance occurs - http://sdkqe-testresults.couchbase.com.s3.amazonaws.com/SDK-SDK/CB-6.6.0-7909/FoEptEject-KV/10-12-20/051611/bb630009e0aef1687b3e1064f7048be8-MC.html

      Logs attached.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris added a comment -

          2020-10-12 07:22:00.8147||Couchbase.Core.ClusterNode|DEBUG|Executing op SelectBucket on 172.23.99.86:11210 with key default and opaque 46968.
          2020-10-12 07:22:00.8336||Couchbase.Core.ClusterNode|DEBUG|Server 172.23.99.86:11210 returned KeyNotFound for op SelectBucket with key default and opaque 46957.
          2020-10-12 07:22:00.8581||Couchbase.Core.ClusterNode|DEBUG|Op failed: Couchbase.Core.IO.Operations.Authentication.SelectBucket: Couchbase.Core.Exceptions.KeyValue.DocumentNotFoundException: Exception of type 'Couchbase.Core.Exceptions.KeyValue.DocumentNotFoundException' was thrown.
          at Couchbase.Core.ClusterNode.ExecuteOp(Action`3 sender, IOperation op, Object state, CancellationToken token) in C:\jenkins\workspace\sdk-net-situational-release\dotnet-situational-all\couchbase-net-client\src\Couchbase\Core\ClusterNode.cs:line 495
          ----------------------Context Info--------------------------
          {"DispatchedFrom":null,"DispatchedTo":null,"DocumentKey":"default","ClientContextId":"46957","Cas":0,"Status":1,"BucketName":"default","CollectionName":null,"ScopeName":null,"Message":"KV Error:

          {Name=\"KEY_ENOENT\", Description=\"Not Found\", Attributes=\"item-only\"}

          "}

          2020-10-12 07:22:00.8581||Couchbase.Core.ClusterNode|ERROR|The Bucket [default] could not be selected. Either it does not exist, is unavailable or the node itself does not have the Data service enabled.
          2020-10-12 07:22:00.8581||Couchbase.Core.IO.Connections.DataFlow.DataFlowConnectionPool|DEBUG|Connection for 172.23.99.86:11210 could not be started.

          jmorris Jeff Morris added a comment - 2020-10-12 07:22:00.8147||Couchbase.Core.ClusterNode|DEBUG|Executing op SelectBucket on 172.23.99.86:11210 with key default and opaque 46968. 2020-10-12 07:22:00.8336||Couchbase.Core.ClusterNode|DEBUG|Server 172.23.99.86:11210 returned KeyNotFound for op SelectBucket with key default and opaque 46957. 2020-10-12 07:22:00.8581||Couchbase.Core.ClusterNode|DEBUG|Op failed: Couchbase.Core.IO.Operations.Authentication.SelectBucket: Couchbase.Core.Exceptions.KeyValue.DocumentNotFoundException: Exception of type 'Couchbase.Core.Exceptions.KeyValue.DocumentNotFoundException' was thrown. at Couchbase.Core.ClusterNode.ExecuteOp(Action`3 sender, IOperation op, Object state, CancellationToken token) in C:\jenkins\workspace\sdk-net-situational-release\dotnet-situational-all\couchbase-net-client\src\Couchbase\Core\ClusterNode.cs:line 495 ---------------------- Context Info -------------------------- {"DispatchedFrom":null,"DispatchedTo":null,"DocumentKey":"default","ClientContextId":"46957","Cas":0,"Status":1,"BucketName":"default","CollectionName":null,"ScopeName":null,"Message":"KV Error: {Name=\"KEY_ENOENT\", Description=\"Not Found\", Attributes=\"item-only\"} "} 2020-10-12 07:22:00.8581||Couchbase.Core.ClusterNode|ERROR|The Bucket [default] could not be selected. Either it does not exist, is unavailable or the node itself does not have the Data service enabled. 2020-10-12 07:22:00.8581||Couchbase.Core.IO.Connections.DataFlow.DataFlowConnectionPool|DEBUG|Connection for 172.23.99.86:11210 could not be started.

          The issue seems to be intermittent so can close this out.

          will.broadbelt Will Broadbelt added a comment - The issue seems to be intermittent so can close this out.

          People

            jmorris Jeff Morris
            will.broadbelt Will Broadbelt
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty