Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.6
    • Fix Version/s: None
    • Component/s: library
    • Labels:
      None

      Description

      User gets a "The type 'Couchbase.HammockHttpClientFactory, Couchbase' cannot be resolved." when trying to use a configuration which specifies this backend.

      Most relevant text from the full post (at https://groups.google.com/forum/?fromgroups=#!topic/couchbase-8091/zSsDSr3Mv54) is below:
      I'm trying to test out the latest build of Couchbase (2.0.1) with the latest SDK and there are some differences with the configuration (or so it seems) and I can't get things to load or when I do I'm concerned that I haven't done it right.

      My configuration looked like this:

      <couchbase>

      <documentNameTransformer type="Couchbase.Configuration.DevelopmentModeNameTransformer, Couchbase" />

      <httpClientFactory type="Couchbase.HammockHttpClientFactory, Couchbase" />

      <servers bucket="dev-bucket" bucketPassword="">

      <add uri="http://localhost:8091/pools/default" />

      </servers>

      <socketPool minPoolSize="1" maxPoolSize="1" connectionTimeout="00:00:10" deadTimeout="00:00:10" />

      </couchbase>

      With that configuration it complains about the httpClientFactory line. I have the latest Couchbase.dll in the bin folder so unclear what is wrong. I dug into the documentation and noticed that there is also an option to use <httpClientFactory type="Couchbase.RestSharpHttpClientFactory, Couchbase" />. Both options result in the following error: The value of the property 'type' cannot be parsed. The error is: The type 'Couchbase.HammockHttpClientFactory, Couchbase' cannot be resolved. Please verify the spelling is correct or that the full type name is provided.

      Also of note, if I comment out all httpClientFactory elements my application loads without any errors. What am I giving up by not having one defined?

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        saakshi.manocha Saakshi Manocha added a comment -

        Hi Kyle!

        We do not distribute the Hammock.dll or RestSharp.dll through our release package. This is because we would not recommend using restsharp at this time, however, we just retained it as an option in case we find any need to use it to address some unforseen compatibility issue.
        RestSharp and Hammock are no longer dependencies of the Couchbase .NET Client Library.
        RestSharp and Hammock will be usable via a separate NuGet project, or from the Couchbase.HttpClients project (via GitHub). These assemblies will not be signed, to avoid collisions with a custom RestSharp, which is unsigned.

        So we suggest either you could use the direct HttpClient or if anyway you would require RestSharp then please download it from the Nuget Package or from the Github Httpclient project.

        kyleheon Kyle Heon added a comment -

        Thank you. I am using the default httpClient at this point without any issues.

        saakshi.manocha Saakshi Manocha added a comment - - edited

        Thanks for the information, Kyle.
        Please confirm that the issue is resolved so that we can mark it as closed.

        kyleheon Kyle Heon added a comment -

        Confirmed.

        saakshi.manocha Saakshi Manocha added a comment -

        Customer confirmed, hence marking it as fixed.


          People

          • Assignee:
            saakshi.manocha Saakshi Manocha
            Reporter:
            ingenthr Matt Ingenthron
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes