Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2886

Couchbase Server 7.0 and SDK Compatibility Matrix

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 3.2.0
    • library
    • None

    Description

      See linked CBD-4123 for more details.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris added a comment - - edited

          I tested Enterprise Edition 7.0.0 build 5274 against 3.0.7, 3.1.0 and 3.1.6 and and all work for default collections/scopes and custom ones. Note that 3.1.7 does not work with build 5274 nor 7.0.0-beta as a server change makes them not compatible, however, there is a fix in 3.1.8/3.2.0.

          jmorris Jeff Morris added a comment - - edited I tested Enterprise Edition 7.0.0 build 5274 against 3.0.7, 3.1.0 and 3.1.6 and and all work for default collections/scopes and custom ones. Note that 3.1.7 does not work with build 5274 nor 7.0.0-beta as a server change makes them not compatible, however, there is a fix in 3.1.8/3.2.0.
          arun.vijayraghavan Arun Vijayraghavan added a comment - - edited

          Jeff Morris so basically what you are saying is 3.1.7 should be skipped it doesnt work with default scopes and collections however the next version 3.1.8 works ? 

           

          in the docs you have mentioned

           

          3.0.1-3.1.6 (bug in 3.1.7 with changes to post beta server builds)

           

          Would it be safe to just say compatible with 3.0.1 through 3.1.6 

          or say compatible with 3.0.1 through 3.1.6  and 3.1.8 (skipping 3.1.5) ? 

           

           

          Are we sure 

          arun.vijayraghavan Arun Vijayraghavan added a comment - - edited Jeff Morris  so basically what you are saying is 3.1.7 should be skipped it doesnt work with default scopes and collections however the next version 3.1.8 works ?    in the docs you have mentioned   3.0.1-3.1.6 (bug in 3.1.7 with changes to post beta server builds)   Would it be safe to just say compatible with 3.0.1 through 3.1.6  or say compatible with 3.0.1 through 3.1.6  and 3.1.8 (skipping 3.1.5) ?      Are we sure 
          jmorris Jeff Morris added a comment -

          Jeff Morris so basically what you are saying is 3.1.7 should be skipped it doesnt work with default scopes and collections however the next version 3.1.8 works ?

          That only applies to 7.0.0-beta - later builds should work in all cases.\

          Would it be safe to just say compatible with 3.0.1 through 3.1.6

          or say compatible with 3.0.1 through 3.1.6 and 3.1.8 (skipping 3.1.5) ?

          3.0.X to latest pretty much with some bugs here and there.

          jmorris Jeff Morris added a comment - Jeff Morris so basically what you are saying is 3.1.7 should be skipped it doesnt work with default scopes and collections however the next version 3.1.8 works ? That only applies to 7.0.0-beta - later builds should work in all cases.\ Would it be safe to just say compatible with 3.0.1 through 3.1.6 or say compatible with 3.0.1 through 3.1.6 and 3.1.8 (skipping 3.1.5) ? 3.0.X to latest pretty much with some bugs here and there.

          People

            jmorris Jeff Morris
            arun.vijayraghavan Arun Vijayraghavan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty