Uploaded image for project: 'Couchbase Python Client Library'
  1. Couchbase Python Client Library
  2. PYCBC-886

Expiry not properly returned or set

    XMLWordPrintable

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.0.0-beta.3
    • 3.0.0
    • library
    • None
    • 1
    • SDK15: Ruby/Coll/Docs

    Description

      There is no expiry option in any of the Upsert, Replace, Insert options. Additionally, the GetOptions has it, but it comes back as None. You would maybe expect this to always be a time delta, just one that has a value of 0 for this? Maybe? Perhaps None is better, but lets get an expiry in there, then make sure that is what comes back.

      I'd really like this in the 3.0.0 release. But I'm leaving the fix version blank for now, lets discuss.

      Attachments

        For Gerrit Dashboard: PYCBC-886
        # Subject Branch Project Status CR V

        Activity

          david.kelly David Kelly added a comment - - edited

          Also – be sure this is implemented correctly – RFC docs explain it, but in fact that is all done by lcb no doubt.

          david.kelly David Kelly added a comment - - edited Also – be sure this is implemented correctly – RFC docs explain it, but in fact that is all done by lcb no doubt.
          david.kelly David Kelly added a comment -

          So...

          Adding expiry to the DurabilityOptionBlock works - the docs get the expiry and expire. The issue is when we try to retrieve it via get (or lookup_in). There was no expiry Spec, so I added one. But, the lookup_in at the collection level seems to not be working for me. This is the issue. Will work through that today.

          Also – there are couchbase_core.subdoc Specs, which couchbase.subdoc uses via some functions. I think that is fine, but perhaps we don't need the couchbase_core.subdoc at all, and can move them into couchbase.subdoc. Maybe after it works

          david.kelly David Kelly added a comment - So... Adding expiry to the DurabilityOptionBlock works - the docs get the expiry and expire. The issue is when we try to retrieve it via get (or lookup_in). There was no expiry Spec, so I added one. But, the lookup_in at the collection level seems to not be working for me. This is the issue. Will work through that today. Also – there are couchbase_core.subdoc Specs, which couchbase.subdoc uses via some functions. I think that is fine, but perhaps we don't need the couchbase_core.subdoc at all, and can move them into couchbase.subdoc. Maybe after it works

          People

            david.kelly David Kelly
            david.kelly David Kelly
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty