Uploaded image for project: 'Couchbase Ruby client library'
  1. Couchbase Ruby client library
  2. RCBC-22

ruby client library is not getting installed under mac


    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Security Level: Public
    • Labels:


      I have couchbase server up and running.

      when i am trying to install libcouchbase as a dependency of the ruby client library, I am getting errors as follow

      i tried with brew install libouchbase
      -> Error: No available formula for libcouchbase

      I tried downloading it and tried to configure it
      -> configure: error: Failed to locate memcached/vbucket.h

      I tried several other options, but no luck. please help on this.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.


        abhishek abhishek created issue -
        ingenthr Matt Ingenthron made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        avsej Sergey Avseyev made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        brett19 Brett Lawson made changes -
        Workflow jira [ 15989 ] Couchbase SDK Workflow [ 44809 ]


          • Assignee:
            ingenthr Matt Ingenthron
            abhishek abhishek
          • Votes:
            0 Vote for this issue
            0 Start watching this issue


            • Created:

              Gerrit Reviews

              There are no open Gerrit changes