Uploaded image for project: 'Couchbase Lite'
  1. Couchbase Lite
  2. CBL-1310

app crashing while fetching the prediction query result

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 2.8.0
    • 3.0
    • .NET
    • Security Level: Public
    • None

    Description

      CBL-2.8.0-148 -only UWP -failed , other platforms looks good
      CBL: 2.8.0-143 -passed
      SG: 2.80-373-RC

      SG: config:

      k: [sg1] => {
      "out.stdout": {
      "SSLCert": "sg_cert.pem",
      "SSLKey": "sg_privkey.pem",
      "adminInterface": "0.0.0.0:4985",
      "compressResponses": false,
      "databases": {
      "db": {
      "allow_conflicts": false,
      "bucket": "travel-sample",
      "delta_sync":

      { "enabled": true }

      ,
      "enable_shared_bucket_access": true,
      "import_docs": true,
      "num_index_replicas": 0,
      "password": "password",
      "server": "http://172.23.106.103:8091",
      "username": "travel-sample"
      }
      },
      "interface": ":4984",
      6 "logging": {
      "debug":

      { "enabled": true }

      },
      "maxFileDescriptors": 90000,
      "maxIncomingConnections": 0
      }
      }

      @summary:
      1. Register the model
      2. Create bulk docs with different types of dictionaries ('four_k', ),('complex_doc'),('simple')
      3. Get the prediction query result and verify whatever the dictionary input is given,
      it should send back same result
      Actual : When we are getting the prediction query results Testserver app is crashing
      Expected: Should be able to get the prediction query results

      http://uberjenkins.sc.couchbase.com:8080/job/CBLITE_DOTNET-UWP-windows-TestSever-Functional-tests/751/testReport/testsuites.CBLTester.CBL_Functional_tests.TestSetup_FunctionalTests/test_predective_queries/test_predictiveQueries_basicInputOutput_four_k__2/

      Test:
      test_predictiveQueries_basicInputOutput

      Command:
      pytest -s --timeout 3600 --liteserv-version=2.8.0-148 --liteserv-host=10.100.161.137 --liteserv-port=8080 --delta-sync --xattrs --sg-ssl --no-conflicts --enable-file-logging --sync-gateway-version=2.8.0-373 --mode=cc --server-version=6.5.1-6299 --liteserv-platform=net-uwp --create-db-per-test=cbl-test -k test_predictiveQueries_basicInputOutput testsuites/CBLTester/CBL_Functional_tests/TestSetup_FunctionalTests

      I do not see any errors in the log , I am trying to manually run on UWP machine but seeing some issues to get the crash report.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          There are no commits yet on this issue.

          People

            manasa.ghanta Manasa Ghanta (Inactive)
            manasa.ghanta Manasa Ghanta (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty