Uploaded image for project: 'Couchbase C client library libcouchbase'
  1. Couchbase C client library libcouchbase
  2. CCBC-1437

Positional Parameter Example Failing on SDK 3.2.0

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Duplicate
    • 3.2.0
    • 3.2.1
    • docs
    • None
    • 1

    Description

      Hi, 

      While upgrading the C SDK on the playground from 3.1.0 to 3.2.0, I found that one of the examples on positional parameters does not work anymore. 

      I tested it locally on my machine as well & get the error 

      $ g++ -Wall -g test.cc -lcouchbase -pthread -o code -std=c++11

      $ ./code

      LCB_ERR_INVALID_ARGUMENT (203)

      The code is attached.

      The code works fine on the playground running 3.1.0 & also for the other SDKs.

      Has something changed in the SDK update that is causing this issue?

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            This is a duplicate of the linked issue and has already been resolved. The fix is planned to be included in the 3.2.1 release of LCB.

            However, please note that we are introducing a new function with a slightly different behavior. With the fix, the behavior of the original lcb_cmdquery_positional_param() will work as it previously did, but it is being deprecated. The new lcb_cmdquery_positional_params() is preferred (notice the plural form), and will allow all of the positional params to be specified in one call.

            For more details:
            https://issues.couchbase.com/browse/CCBC-1429

            ray.cardillo Ray Cardillo added a comment - This is a duplicate of the linked issue and has already been resolved. The fix is planned to be included in the 3.2.1 release of LCB. However, please note that we are introducing a new function with a slightly different behavior. With the fix, the behavior of the original lcb_cmdquery_positional_param() will work as it previously did, but it is being deprecated. The new lcb_cmdquery_positional_params() is preferred (notice the plural form), and will allow all of the positional params to be specified in one call. For more details: https://issues.couchbase.com/browse/CCBC-1429

            People

              avsej Sergey Avseyev
              nithish.raghunandanan Nithish Raghunandanan
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty