Uploaded image for project: 'Couchbase C client library libcouchbase'
  1. Couchbase C client library libcouchbase
  2. CCBC-935

Orphaned responses should be logged at WARN

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 2.9.1
    • None
    • None
    • 1

    Description

      Orphaned responses should be logged at WARN, or equivalent, level. Currently both threshold and orphaned spans are logged at INFO level.

      https://github.com/couchbase/libcouchbase/blob/master/src/tracing/threshold_logging_tracer.cc#L128 

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          but Matt Ingenthron said that everything captured in threshold tracing logger should go on INFO

          avsej Sergey Avseyev added a comment - but Matt Ingenthron said that everything captured in threshold tracing logger should go on INFO

          Threshold spans should be logged at INFO as they haven't actually failed, just crossed a given threshold.

          Orphaned responses should be logged at WARN because they can be matched against Timeout message correlation IDs to help identify what was the cause.

          mike.goldsmith Michael Goldsmith added a comment - Threshold spans should be logged at INFO as they haven't actually failed, just crossed a given threshold. Orphaned responses should be logged at WARN because they can be matched against Timeout message correlation IDs to help identify what was the cause.

          Build libcouchbase-2.8.5-203 contains libcouchbase commit d88c913 with commit message:
          CCBC-935: display orphan tracer report on WARN log level

          build-team Couchbase Build Team added a comment - Build libcouchbase-2.8.5-203 contains libcouchbase commit d88c913 with commit message: CCBC-935 : display orphan tracer report on WARN log level

          Build couchbase-server-6.0.0-1259 contains libcouchbase commit d88c913 with commit message:
          CCBC-935: display orphan tracer report on WARN log level

          build-team Couchbase Build Team added a comment - Build couchbase-server-6.0.0-1259 contains libcouchbase commit d88c913 with commit message: CCBC-935 : display orphan tracer report on WARN log level

          Build couchbase-server-6.5.0-1012 contains libcouchbase commit d88c913 with commit message:
          CCBC-935: display orphan tracer report on WARN log level

          build-team Couchbase Build Team added a comment - Build couchbase-server-6.5.0-1012 contains libcouchbase commit d88c913 with commit message: CCBC-935 : display orphan tracer report on WARN log level

          People

            avsej Sergey Avseyev
            mike.goldsmith Michael Goldsmith
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty