Uploaded image for project: 'Couchbase Go SDK'
  1. Couchbase Go SDK
  2. GOCBC-1021

UpsertDesignDocument requests routed to wrong bucket

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.1.8
    • 2.2.0
    • None
    • None
    • 1

    Description

      Was getting errors(design document not found) when running design document upsert to programmable add view indexes. Started going through the code and found out the path request was including the bucket name at the beginning of the path. Worked after testing adding the bucket name

      bucket_viewindexes.go line 342
      Path: fmt.Sprintf("/_design/%s", ddocName),
      should be Path: fmt.Sprintf("/%s/_design/%s", bucketName, ddocName),

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          OK thanks Brian Voelker I believe that I understand what the issue is now. I'm going to resolve this issue as not a bug because the behaviour on the view manager side is correct. I will add more detail in the other ticket about what is happening.

          charles.dixon Charles Dixon added a comment - OK thanks Brian Voelker I believe that I understand what the issue is now. I'm going to resolve this issue as not a bug because the behaviour on the view manager side is correct. I will add more detail in the other ticket about what is happening.
          charles.dixon Charles Dixon added a comment - - edited

          Actually, I believe this to be an issue in its own right. Exhbiting the same problem as the other issue but via a different avenue - requests get sent to the agent group which mean they are not routed via the agent and therefore can go to incorrect endpoints.

          charles.dixon Charles Dixon added a comment - - edited Actually, I believe this to be an issue in its own right. Exhbiting the same problem as the other issue but via a different avenue - requests get sent to the agent group which mean they are not routed via the agent and therefore can go to incorrect endpoints.

          Build sync_gateway-3.0.0-96 contains gocb commit 625accf with commit message:
          GOCBC-1021: Route bucket level http requests to agents not agent group

          build-team Couchbase Build Team added a comment - Build sync_gateway-3.0.0-96 contains gocb commit 625accf with commit message: GOCBC-1021 : Route bucket level http requests to agents not agent group

          Build couchbase-server-7.0.0-4715 contains gocb commit 625accf with commit message:
          GOCBC-1021: Route bucket level http requests to agents not agent group

          build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-4715 contains gocb commit 625accf with commit message: GOCBC-1021 : Route bucket level http requests to agents not agent group

          Build couchbase-server-7.1.0-1767 contains gocb commit 625accf with commit message:
          GOCBC-1021: Route bucket level http requests to agents not agent group

          build-team Couchbase Build Team added a comment - Build couchbase-server-7.1.0-1767 contains gocb commit 625accf with commit message: GOCBC-1021 : Route bucket level http requests to agents not agent group

          People

            charles.dixon Charles Dixon
            bvoelker Brian Voelker
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty