Uploaded image for project: 'Couchbase Java Client'
  1. Couchbase Java Client
  2. JCBC-1728

Collection manager not parsing errors correctly

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.0.9
    • 3.1.1
    • None
    • 1

    Description

      There are a number of errors that I think have changed their error message response from the server and therefore the errors are not being parsed correctly.

      Here's a list of the current (7.0.0-3435 internal beta) error responses:

      Scope already exists:
      {"errors":{"_":"Scope with name \"2d33a596-8\" already exists"}}

      Collection already exists:
      {"errors":{"_":"Collection with name \"b185d9f9-0\" in scope \"7df92294-3\" already exists"}}

      Scope not found:
      {"errors":{"_":"Unknown error {error,{scope_not_found,\"foobar\"}}"}}

      Collection not found
      {"errors":{"_":"Unknown error {error,{collection_not_found,\"a9e4f276-3\",\"1141f1d0-b\"}}"}}

       

      There are a number of test failures related to this: http://sdk.jenkins.couchbase.com/view/Nightly/job/jvm/job/jvm-clients/job/couchbase-jvm-clients-scipted-build-pipeline/521/testReport/com.couchbase.client.java.manager.collection/CollectionManagerIntegrationTest/

       

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            Will Broadbelt: we were reviewing this earlier today. The "7.0mustpass" label really means that it needs to be fixed for the Cheshire Cat beta, which is scheduled for mid-November. If we want that, then we'd need to fix it and queue up a special release of the SDK. I think that may not be what you'd intended here?

            I don't think it's a blocker for 7.0beta in any functional way, but maybe I'm wrong. Maybe I'd propose we add the "affects-CC-testing" label and ask Michael Nitschinger and team to queue it up for the next release? Let me know what you think Will Broadbelt.

            ingenthr Matt Ingenthron added a comment - Will Broadbelt : we were reviewing this earlier today. The "7.0mustpass" label really means that it needs to be fixed for the Cheshire Cat beta, which is scheduled for mid-November. If we want that, then we'd need to fix it and queue up a special release of the SDK. I think that may not be what you'd intended here? I don't think it's a blocker for 7.0beta in any functional way, but maybe I'm wrong. Maybe I'd propose we add the "affects-CC-testing" label and ask Michael Nitschinger and team to queue it up for the next release? Let me know what you think Will Broadbelt .

            Matt Ingenthron: Yes I agree a special release would be overkill. Having the proper named exceptions as intended would be nice, but doesn't affect the overall functionality much, so the 'affects-CC-testing' label is more appropriate here. I have updated the ticket as such.

            will.broadbelt Will Broadbelt added a comment - Matt Ingenthron : Yes I agree a special release would be overkill. Having the proper named exceptions as intended would be nice, but doesn't affect the overall functionality much, so the 'affects-CC-testing' label is more appropriate here. I have updated the ticket as such.

            Michael Nitschinger: can you triage this accordingly? Thanks!

            ingenthr Matt Ingenthron added a comment - Michael Nitschinger : can you triage this accordingly? Thanks!

            People

              daschl Michael Nitschinger
              will.broadbelt Will Broadbelt
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty