Uploaded image for project: 'Java Couchbase JVM Core'
  1. Java Couchbase JVM Core
  2. JVMCBC-958

Seeing 'COLLECTION_MAP_REFRESH_IN_PROGRESS' in steady state conditions

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • None
    • None
    • Java client:3.1.0
      CB server Enterprise Edition 7.0.0 build 4733
    • 1

    Description

      Scenario:

      1. Two node cluster, Couchbase bucket (replica=1, scope=3, collections=2 per scope)
      2. Load each collection with 100 docs initially into all collections
      3. Open a separate client for testing sync_write outcome
      4. Stop persistence on one of the node using cbepctl command
      5. Load single doc with durability=MAJORITY_AND_PERSIST_TO_ACTIVE on 5 collections in parallel with timeout=60sec, such that the op won't timeout
      6. Using the client opened during step#3 try the same doc_op on same doc_key to validateĀ  SYNC_WRITE_IN_PROGRESS outcome

      Observation:

      Seeing COLLECTION_MAP_REFRESH_IN_PROGRESS during one of the five operations. All other operations results in valid KV_SYNC_WRITE_IN_PROGRESS.

      Expected behavior:

      Should not see MAP_REFRESH_IN_PROGRESS, since the client has been already opened well before the doc_ops and the simulated error here is only STOP_PERSISTENCE(which has no direct effect on client)

      Cbcollect logs:
      https://cb-engineering.s3.amazonaws.com/c_map_refresh_in_progress/collectinfo-2021-03-23T120441-ns_1%40172.23.105.155.zipĀ 
      https://cb-engineering.s3.amazonaws.com/c_map_refresh_in_progress/collectinfo-2021-03-23T120441-ns_1%40172.23.105.211.zip
      Attaching test run logs test.log and pcap col_map_refresh.pcap

      QE test:

      epengine.collection_crud_negative.CollectionDurabilityTests:
        test_sync_write_in_progress,nodes_init=2,replicas=1,num_items=100,sdk_timeout=60,doc_ops=create;create,bucket_spec=single_bucket.three_scopes_two_collections
      

      Attachments

        1. col_map_refresh.pcap
          22.50 MB
        2. JavaSDK_7_clients.log
          3.33 MB
        3. JavaSDK_with_patch.log
          5.07 MB
        4. JavaSDK.log
          14.33 MB
        5. test_log_with_patch.txt
          14 kB
        6. test_run.log
          9 kB
        7. test.log
          184 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          The change I asked you to run is still helpful since it optimizes a couple things, but overall the states are expected to happen.

          daschl Michael Nitschinger added a comment - The change I asked you to run is still helpful since it optimizes a couple things, but overall the states are expected to happen.

          Updated the testcase to avoid fail fast testing in collection specific tests.

          Note: Still fail_fast testing is part of durability suite

          ashwin.govindarajulu Ashwin Govindarajulu added a comment - Updated the testcase to avoid fail fast testing in collection specific tests. Note : Still fail_fast testing is part of durability suite

          Ashwin Govindarajuluwhat's the status of this ticket, with the workaround applied - can it be closed?

          daschl Michael Nitschinger added a comment - Ashwin Govindarajulu what's the status of this ticket, with the workaround applied - can it be closed?

          Michael Nitschinger Yes this can be closed. Have modified the testcase to handle this state.

          ashwin.govindarajulu Ashwin Govindarajulu added a comment - Michael Nitschinger Yes this can be closed. Have modified the testcase to handle this state.

          Closing this ticket.

          ashwin.govindarajulu Ashwin Govindarajulu added a comment - Closing this ticket.

          People

            ashwin.govindarajulu Ashwin Govindarajulu
            ashwin.govindarajulu Ashwin Govindarajulu
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty