Uploaded image for project: 'Couchbase Kubernetes'
  1. Couchbase Kubernetes
  2. K8S-1577

Remove default fsgroup from OLM deployment

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.1.0
    • openshift
    • 41: 2.2, Bugs.
    • 2

    Description

      Since the operator validation requires fsgroup the default value for the default projects/namespaces is provided.  Problem is, this value will always need to be changed for different projects/namespaces so we should do 2 things:

      1. Remove fsgroup from csv
      2. Remove requirement from operator validation

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            Anil Kumar can we move this out of 2.1?

            arunkumar Arunkumar Senthilnathan (Inactive) added a comment - Anil Kumar can we move this out of 2.1?

            Arunkumar Senthilnathan I discussed this with Anil Kumar & he said, its important to go with CAO 2.1

            roshani.sanghavi Roshani Sanghavi (Inactive) added a comment - - edited Arunkumar Senthilnathan I discussed this with Anil Kumar & he said, its important to go with CAO 2.1

            Security Context is already set as optional for 2.1

              SecurityContext *v1.PodSecurityContext `json:"securityContext,omitempty"` 

            Via omitempty

            tommie Tommie McAfee added a comment - Security Context is already set as optional for 2.1 SecurityContext *v1.PodSecurityContext `json: "securityContext,omitempty" ` Via omitempty

            People

              tommie Tommie McAfee
              tommie Tommie McAfee
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty