Uploaded image for project: 'Couchbase Kubernetes'
  1. Couchbase Kubernetes
  2. K8S-1883

Ephemeral bucket template for Helm

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.0.2
    • helm, kubernetes
    • None
    • 1

    Description

      Currently we only have Couchbasebucket template. We need to create a ephemeral bucket for the helm chart.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            tommie Tommie McAfee added a comment - Hi Tin, Ephemeral Bucket templates exist in 2.1 chart https://github.com/couchbase-partners/helm-charts/blob/master/couchbase-operator/values.yaml#L265  
            tin.tran Tin Tran added a comment -

            Re-open this issue per discussion with Tommie McAfee to backport this template to 2.0.2

            tin.tran Tin Tran added a comment - Re-open this issue per discussion with Tommie McAfee to backport this template to 2.0.2
            shachar.bar Shachar Bar added a comment -

            Hi Tommie,

             

            I wonder when the ephemeral bucket template will be back ported to the v1 chart, as the customer is asking for a fix.

            He is using CAO 2.0.2 with CB 6.0.4 and hence is using helm chart v1.

             

            Thanks.

            shachar.bar Shachar Bar added a comment - Hi Tommie,   I wonder when the ephemeral bucket template will be back ported to the v1 chart, as the customer is asking for a fix. He is using CAO 2.0.2 with CB 6.0.4 and hence is using helm chart v1.   Thanks.

            Hi looks like this feature exists in 2.0.2.  Specify the bucket 'kind' in order to change the bucket type... ie

             buckets:
              default:
                kind: CouchbaseEphemeralBucket 
                evictionPolicy: nruEviction
            

            https://github.com/couchbase-partners/helm-charts/commit/7db3de4fd799789b724a2c05a15fdbbff75db563#diff-3754e5c7956ff4f53c444bfc4cfccbf2192d4890f5d8c27df29dab68c33b85dd

             

            tommie Tommie McAfee added a comment - Hi looks like this feature exists in 2.0.2.  Specify the bucket 'kind' in order to change the bucket type... ie buckets: default : kind: CouchbaseEphemeralBucket evictionPolicy: nruEviction https://github.com/couchbase-partners/helm-charts/commit/7db3de4fd799789b724a2c05a15fdbbff75db563#diff-3754e5c7956ff4f53c444bfc4cfccbf2192d4890f5d8c27df29dab68c33b85dd  
            shachar.bar Shachar Bar added a comment -

            Hi Tommie,

             

            Trying to deploy this we get the following error:

            Error: CouchbaseBucket.couchbase.com "default" is invalid: spec.evictionPolicy: Invalid value: "": spec.evictionPolicy in body should match '^valueOnly|fullEviction$'
            

            The `yaml` code is below:

            default:     
               kind: CouchbaseEphemeralBucket     
               name: myepbucket     
               memoryQuota: 100Mi     
               evictionPolicy: nruEviction     
               replicas: 0     
               ioPriority: high     
               conflictResolution: seqno     
               enableFlush: true     
               enableIndexReplica: false     
               compressionMode: "passive"
            

            shachar.bar Shachar Bar added a comment - Hi Tommie,   Trying to deploy this we get the following error: Error: CouchbaseBucket.couchbase.com "default" is invalid: spec.evictionPolicy: Invalid value: "" : spec.evictionPolicy in body should match '^valueOnly|fullEviction$' The `yaml` code is below: default :     kind: CouchbaseEphemeralBucket     name: myepbucket     memoryQuota: 100Mi     evictionPolicy: nruEviction     replicas: 0     ioPriority: high     conflictResolution: seqno     enableFlush: true     enableIndexReplica: false     compressionMode: "passive"

            Got it. Do helm repo update and try again.

             

            Problem was the version fetching didn't work as expected.  Changes have been back ported to 2.0.2 but with incrementing numbers.  So the latest 2.0.2 was:

            helm install ... --version 2.0.209 

             'Fix' then was to push directly to 2.0.2 itself and keep the incremented versions for historical purposes.

            A good resource to check latest chart versions is here: https://artifacthub.io/packages/helm/couchbase/couchbase-operator/2.0.209

            tommie Tommie McAfee added a comment - Got it. Do helm repo update and try again.   Problem was the version fetching didn't work as expected.  Changes have been back ported to 2.0.2 but with incrementing numbers.  So the latest 2.0.2 was: helm install ... --version 2.0 . 209  'Fix' then was to push directly to 2.0.2 itself and keep the incremented versions for historical purposes. A good resource to check latest chart versions is here:  https://artifacthub.io/packages/helm/couchbase/couchbase-operator/2.0.209
            shachar.bar Shachar Bar added a comment -

            Thanks Tommie,

             

            The customer has confirmed it is now working and he managed to create an Ephemeral bucket upon deploying AO 2.0.2 with CB 6.0.4, using the latest 2.0.2  helm chart.

             

            shachar.bar Shachar Bar added a comment - Thanks Tommie,   The customer has confirmed it is now working and he managed to create an Ephemeral bucket upon deploying AO 2.0.2 with CB 6.0.4, using the latest 2.0.2  helm chart.  

            People

              tommie Tommie McAfee
              tin.tran Tin Tran
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty