Uploaded image for project: 'Couchbase Kubernetes'
  1. Couchbase Kubernetes
  2. K8S-2508

Non-kv nodes do not have kv port in alternative address list

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.3.0
    • operator
    • None
    • 1

    Description

      This leads to constant reconciling with MDS deployments.

      Notice the service exposes kv port

      cbtest3-couchbase-cluster-0002           NodePort    10.0.66.65     <none>        8091:32525/TCP,18091:31641/TCP,11210:32073/TCP,11207:32192/TCP,8092:32612/TCP,18092:30827/TCP,8093:31039/TCP,18093:32619/TCP                                                                                                                                                                                                                                                          31m
       

       

      But Couchbase itself does not list this port

      "alternateAddresses":{"external":{"hostname":"10.240.0.4","ports":{"mgmt":32525,"mgmtSSL":31641,"n1ql":31039,"n1qlSSL":32619}}}} 

       

      So the operator doesn't progress in reconciling the world

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          simon.murray Simon Murray added a comment -

          Oh that's not good, is this a server problem?  I'd expect KV to always be exposed because of GCCCP bootstrap.

          simon.murray Simon Murray added a comment - Oh that's not good, is this a server problem?  I'd expect KV to always be exposed because of GCCCP bootstrap.

          Well at least it isn't a regression, looks like this was always happening, but just now being exposed with additional logging that occurs in 2.3.

           

          Not sure if server is doing this or we haven't been sending correct alt address request.

          tommie Tommie McAfee added a comment - Well at least it isn't a regression, looks like this was always happening, but just now being exposed with additional logging that occurs in 2.3.   Not sure if server is doing this or we haven't been sending correct alt address request.

          Server silently rejects kv ports when provided to nodes not running data ports.

          tommie Tommie McAfee added a comment - Server silently rejects kv ports when provided to nodes not running data ports.
          simon.murray Simon Murray added a comment -

          Sounds like a bug to me, consult with Finlay and see what he says.  Sure we still work in the sense we can bootstrap against the data nodes.  Guess in the short term, just hack around it :shrug:

          simon.murray Simon Murray added a comment - Sounds like a bug to me, consult with Finlay and see what he says.  Sure we still work in the sense we can bootstrap against the data nodes.  Guess in the short term, just hack around it :shrug:

          Yea MB-49376

           

          tommie Tommie McAfee added a comment - Yea MB-49376  

          Build couchbase-operator-2.3.0-192 contains couchbase-operator commit 1cf6acc with commit message:
          K8S-2508: Ensure data ports exist in alternative addresses config

          build-team Couchbase Build Team added a comment - Build couchbase-operator-2.3.0-192 contains couchbase-operator commit 1cf6acc with commit message: K8S-2508 : Ensure data ports exist in alternative addresses config

          People

            tommie Tommie McAfee
            tommie Tommie McAfee
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty