Uploaded image for project: 'Couchbase Kubernetes'
  1. Couchbase Kubernetes
  2. K8S-964

K8S Helm Chart not validating on EKS

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 1.2.0
    • 1.2.1
    • helm

    Description

      REQ

      I was trying to test the HELM chart deployment and when I run the following command:

      helm install couchbase/couchbase-operator

      I get the following error:

      Error: validation failed: error validating "": error validating data: [ValidationError(Deployment.spec.template.spec.containers[0]): unknown field "failureThreshold" in io.k8s.api.core.v1.Container, ValidationError(Deployment.spec.template.spec.containers[0]): unknown field "httpGet" in io.k8s.api.core.v1.Container, ValidationError(Deployment.spec.template.spec.containers[0]): unknown field "initialDelaySeconds" in io.k8s.api.core.v1.Container, ValidationError(Deployment.spec.template.spec.containers[0]): unknown field "periodSeconds" in io.k8s.api.core.v1.Container, ValidationError(Deployment.spec.template.spec.containers[0].resources): unknown field "cpu" in io.k8s.api.core.v1.ResourceRequirements, ValidationError(Deployment.spec.template.spec.containers[0].resources): unknown field "memory" in io.k8s.api.core.v1.ResourceRequirements]
      

      BACKGROUND

      I am attempting to deploy to an EKS cluster running kubernetes 1.12 in the US-EAST-1 Region.

      I installed HELM and TIller successfully using the RBAC-Tiller.yaml specified in our documentation.

      HQ-Computer:helm craigkovar$ helm version
      Client: &version.Version{SemVer:"v2.14.0", GitCommit:"05811b84a3f93603dd6c2fcfe57944dfa7ab7fd0", GitTreeState:"clean"}
      Server: &version.Version{SemVer:"v2.14.0", GitCommit:"05811b84a3f93603dd6c2fcfe57944dfa7ab7fd0", GitTreeState:"clean"}

      Also

       

      HQ-Computer:helm craigkovar$ helm search couchbase
      NAME CHART VERSION APP VERSION DESCRIPTION
      couchbase/couchbase-cluster 0.1.2 1.2 Couchbase Server is a NoSQL document database with a dist...
      couchbase/couchbase-operator 0.1.2 1.2 A Helm chart to deploy the Couchbase Autonomous Operator ...
      HQ-Computer:helm craigkovar${noformat}
       

      Attachments

        Issue Links

          For Gerrit Dashboard: K8S-964
          # Subject Branch Project Status CR V

          Activity

            simon.murray Simon Murray added a comment -

            So while that field is correctly named, in the right place in the spec it's not in the CRD schema.  I'm assuming that helm is now validating what's in the chart matches what's advertised.  While technically this is ostensibly a packaging change to add a new CRD, it's also a point release, so we cannot fix until 1.2.1.

            simon.murray Simon Murray added a comment - So while that field is correctly named, in the right place in the spec it's not in the CRD schema.  I'm assuming that helm is now validating what's in the chart matches what's advertised.  While technically this is ostensibly a packaging change to add a new CRD, it's also a point release, so we cannot fix until 1.2.1.
            simon.murray Simon Murray added a comment -

            See comments

            simon.murray Simon Murray added a comment - See comments
            simon.murray Simon Murray added a comment -

            After some digging the change that caused the error was fixed in 2.14.1, so please upgrade helm/tiller and it will go away

            simon.murray Simon Murray added a comment - After some digging the change that caused the error was fixed in 2.14.1, so please upgrade helm/tiller and it will go away
            simon.murray Simon Murray added a comment -

            As stated previously this is a bug in Helm that has been reverted, so closing... for now

            simon.murray Simon Murray added a comment - As stated previously this is a bug in Helm that has been reverted, so closing... for now

            Summary: Due to a known issue in Helm 2.14.0, attempting to install the Couchbase cluster would result in validation errors, even for correctly-configured charts.

            Workaround: Use a version of Helm other than 2.14.0.

            eric.schneider Eric Schneider (Inactive) added a comment - Summary : Due to a known issue in Helm 2.14.0, attempting to install the Couchbase cluster would result in validation errors, even for correctly-configured charts. Workaround : Use a version of Helm other than 2.14.0.

            People

              simon.murray Simon Murray
              craig.kovar Craig Kovar (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty