Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-22880

N1QL query panel becomes inaccessible when indexer rebalance is going on

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.0
    • Fix Version/s: 5.0.0
    • Component/s: query
    • Labels:
      None
    • Environment:
      5.0.0-2000
    • Triage:
      Untriaged
    • Is this a Regression?:
      Unknown

      Description

      Steps to reproduce:

      1) Create a 4 node cluster : 1 kv, 2 indexer, 1 n1ql

      2) Create multiple secondary indexes.

      3) Remove one of the indexer nodes and start rebalance.

      4) While step 3 is in progress, run "CREATE INDEX index_name ON default(age) USING GSI WITH {'defer_build': True};" from the n1ql node, they will keep failing with "Unexpected server error"(which is expected).

      5) Continue running the create index commands from the n1ql query panel, after some attempts query panel becomes inaccessible with "no query nodes were found on this cluster, so N1QL querying is not possible" message.

      However a browser refresh fixes the issue and restores the query panel.

      Will attach logs.

        Attachments

        1. index_node1.zip
          33.39 MB
        2. index_node2.zip
          16.06 MB
        3. kv.zip
          54.13 MB
        4. n1ql_node.zip
          27.57 MB
        5. Screen Shot 2017-02-18 at 8.20.33 PM.png
          Screen Shot 2017-02-18 at 8.20.33 PM.png
          329 kB
        6. Screen Shot 2017-02-18 at 8.21.08 PM.png
          Screen Shot 2017-02-18 at 8.21.08 PM.png
          372 kB
        7. Screen Shot 2017-02-19 at 11.51.21 AM.png
          Screen Shot 2017-02-19 at 11.51.21 AM.png
          596 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          jliang John Liang added a comment -

          Looks like same issue as https://issues.couchbase.com/browse/MB-22847. You don't need rebalancing to trigger this.

          jliang John Liang added a comment -

          Bala, if you want to test create index during rebalance, use cbs-shell for now.

          Sitaram.Vemulapalli Sitaram Vemulapalli added a comment - - edited

          Please try with 5.0.0-2025 or higher. Which has these fixes MB-22846, MB-22854, MB-22859, Fix panic on slice bounds out of range.

          Sitaram.Vemulapalli Sitaram Vemulapalli added a comment -

          Fixed by MB-22846, MB-22854, MB-22859, Fix panic on slice bounds out of range.
          Try 5.0.0-2025 or higher. if problem still present re-open

          Balakumaran.Gopal Balakumaran Gopal added a comment -

          Validate this on Enterprise Edition 5.0.0 build 2824 by creating index/querying while GSI rebalance is running. Worked fine.


            People

            • Assignee:
              Balakumaran.Gopal Balakumaran Gopal
              Reporter:
              Balakumaran.Gopal Balakumaran Gopal
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.