Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-36239

Intermittent failure ep_testsuite_dcp (Windows)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 6.5.0
    • Fix Version/s: None
    • Component/s: test-execution
    • Labels:
      None
    • Triage:
      Untriaged
    • Is this a Regression?:
      Unknown

      Description

      Running [0030/0097]: test producer stream request coldness (couchstore).....\kv_engine\engines\ep\tests\ep_testsuite_dcp.cc:592 Test failed: `' (Expected `1', got `2' - Unexpected number of snapshot markers)

      Fails somewhat consistently on windows VM 172.23.120.146.

      I reproduce it by running this script...

      #!/bin/bash

      iter=1

      while [ 1 ] ; do

          echo "Iteration $iter"

          ctest -j 20 --output-on-failure --no-compress-output -T Test --tests-regex "ep-engine_ep_unit_tests|ep_testsuite_dcp.full_eviction.magma|ep_testsuite_dcp.value_eviction|ep_testsuite.full_eviction|ep_testsuite.value_eviction|ep_testsuite_basic.full_eviction|ep_testsuite_basic.value_eviction|ep_testsuite_checkpoint.full_eviction|ep_testsuite_checkpoint.value_eviction|ep_testsuite_xdcr.full_eviction|ep_testsuite_xdcr.value_eviction" > test.out1 2>&1

          grep FAILED test.out

          if [ $? == 0 ] ; then

              exit 1

          fi

          iter=$((iter + 1))

      done

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

            drigby Dave Rigby added a comment -

            Duplicate of MB-34301.

            ben.huddleston Ben Huddleston added a comment -

            (Hopefully) fixed MB-34301 so closing


              People

              Assignee:
              scott.lashley Scott Lashley
              Reporter:
              scott.lashley Scott Lashley
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes

                    PagerDuty