Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-36324

make simple-test failing (xdcr.uniXDCR.unidirectional): "XDCRException: Replication with Src bucket: default and Target bucket: default not found"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: master
    • Fix Version/s: 6.5.0
    • Component/s: test-execution, XDCR
    • Labels:
      None
    • Triage:
      Untriaged
    • Is this a Regression?:
      Yes

      Description

      As seen during KV-Engine master periodic post-commit job #525, test xdcr.uniXDCR.unidirectiona is now failing:

      ======================================================================
      ERROR: load_with_ops (xdcr.uniXDCR.unidirectional)
      ----------------------------------------------------------------------
      Traceback (most recent call last):
        File "pytests/xdcr/uniXDCR.py", line 31, in load_with_ops
          self.setup_xdcr_and_load()
        File "pytests/xdcr/xdcrnewbasetests.py", line 3352, in setup_xdcr_and_load
          self.setup_xdcr()
        File "pytests/xdcr/xdcrnewbasetests.py", line 3349, in setup_xdcr
          cluster.set_global_checkpt_interval(self._checkpoint_interval)
        File "pytests/xdcr/xdcrnewbasetests.py", line 1265, in set_global_checkpt_interval
          self.set_xdcr_param("checkpointInterval",value)
        File "pytests/xdcr/xdcrnewbasetests.py", line 2272, in set_xdcr_param
          RestConnection(self.__master_node).set_xdcr_param(src_bucket.name, dst_bucket.name, param, value)
        File "lib/membase/api/rest_client.py", line 2747, in set_xdcr_param
          replication = self.get_replication_for_buckets(src_bucket_name, dest_bucket_name)
        File "lib/membase/api/rest_client.py", line 2734, in get_replication_for_buckets
          format(src_bucket_name, dest_bucket_name))
      XDCRException: Replication with Src bucket: default and Target bucket: default not found
      

      Changelog since last successful build (#524): http://cv.jenkins.couchbase.com/view/Commit%20Validation/view/kv_engine/job/kv_engine-master-post-commit-TSan/525/changes

      Logs: http://cv.jenkins.couchbase.com/view/Commit%20Validation/view/kv_engine/job/kv_engine-master-post-commit-TSan/525/consoleFull#672079589712a389b-c7bc-46ec-bcae-02346ef3ce1b

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          drigby Dave Rigby added a comment -

          Assigning to XDCR (Neil Huang) in the first instance given that from the changelog the only change since the last good build which appears related is http://review.couchbase.org/#/c/115620

          drigby Dave Rigby added a comment -
          ritam.sharma Ritam Sharma added a comment -
          pavithra.mahamani Pavithra Mahamani added a comment -

            People

            Assignee:
            neil.huang Neil Huang
            Reporter:
            drigby Dave Rigby
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty