Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-38382

[CX] ArrayIndexOutOfBoundsException in BTreeAccessMethod

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 6.0.1
    • 6.5.0, 6.0.4
    • analytics
    • None
    • Untriaged
    • Unknown

    Description

      The following exception was seen in a customer's logs. Unfortunately, the logs containing the query were rolled over.

      2019-11-09T00:21:10.350-06:00 ERRO CBAS.apache.asterix [Executor-2133:ClusterController] Unexpected exception2019-11-09T00:21:10.350-06:00 ERRO CBAS.apache.asterix [Executor-2133:ClusterController] Unexpected exceptionjava.lang.ArrayIndexOutOfBoundsException: Index 2 out of bounds for length 2 at org.apache.asterix.optimizer.rules.am.BTreeAccessMethod.createIndexSearchPlan(BTreeAccessMethod.java:400) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.BTreeAccessMethod.applySelectPlanTransformation(BTreeAccessMethod.java:182) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:423) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.checkAndApplyTheSelectTransformation(IntroduceSelectAccessMethodRule.java:335) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.asterix.optimizer.rules.am.IntroduceSelectAccessMethodRule.rewritePre(IntroduceSelectAccessMethodRule.java:167) ~[asterix-algebra.jar:6.0.1-2037] at org.apache.hyracks.algebricks.core.rewriter.base.AbstractRuleController.rewriteOperatorRef(AbstractRuleController.java:90) ~[algebricks-core.jar:6.0.1-2037] at org.apache.hyracks.algebricks.compiler.rewriter.rulecontrollers.SequentialFixpointRuleController.rewriteWithRuleCollection(SequentialFixpointRuleController.java:53) ~[algebricks-compiler.jar:6.0.1-2037] at org.apache.hyracks.algebricks.core.rewriter.base.HeuristicOptimizer.runOptimizationSets(HeuristicOptimizer.java:102) ~[algebricks-core.jar:6.0.1-2037] at org.apache.hyracks.algebricks.core.rewriter.base.HeuristicOptimizer.optimize(HeuristicOptimizer.java:82) ~[algebricks-core.jar:6.0.1-2037] at org.apache.hyracks.algebricks.compiler.api.HeuristicCompilerFactoryBuilder$1$1.optimize(HeuristicCompilerFactoryBuilder.java:90) ~[algebricks-compiler.jar:6.0.1-2037] at org.apache.asterix.api.common.APIFramework.compileQuery(APIFramework.java:252) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.rewriteCompileQuery(QueryTranslator.java:1993) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.lambda$handleQuery$3(QueryTranslator.java:2500) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.createAndRunJob(QueryTranslator.java:2625) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.deliverResult(QueryTranslator.java:2544) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.handleQuery(QueryTranslator.java:2513) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.translator.QueryTranslator.compileAndExecute(QueryTranslator.java:393) ~[asterix-app.jar:6.0.1-2037] at org.apache.asterix.app.message.ExecuteStatementRequestMessage.handle(ExecuteStatementRequestMessage.java:136) [asterix-app.jar:6.0.1-2037] at org.apache.asterix.messaging.CCMessageBroker.receivedMessage(CCMessageBroker.java:66) [asterix-app.jar:6.0.1-2037] at org.apache.hyracks.control.cc.work.ApplicationMessageWork$1.run(ApplicationMessageWork.java:55) [hyracks-control-cc.jar:6.0.1-2037] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?] 
      

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          This is a duplicate of https://issues.couchbase.com/browse/MB-36702
          which was fixed in 6.0.4

          dmitry.lychagin Dmitry Lychagin added a comment - This is a duplicate of https://issues.couchbase.com/browse/MB-36702 which was fixed in 6.0.4

          People

            murtadha.hubail Murtadha Hubail
            murtadha.hubail Murtadha Hubail
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty