Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-40084

make simple-test is broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Test Blocker
    • Resolution: Fixed
    • Affects Version/s: Cheshire-Cat
    • Fix Version/s: 7.0.0
    • Component/s: test-execution
    • Labels:
      None
    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown

      Description

      make simple-test is broken most likely by this change:
      http://review.couchbase.org/c/testrunner/+/128698

      ERROR: suite_tearDown (unittest.loader._FailedTest)
      14:24:46 ----------------------------------------------------------------------
      14:24:46 AttributeError: type object 'unidirectional' has no attribute 'suite_tearDown'
      

      Or by this change:
      http://review.couchbase.org/c/kv_engine/+/130892

      Due to this warning:

      13:49:26 /home/couchbase/jenkins/workspace/ns-server-simple-test/kv_engine/tests/unsigned_leb128/unsigned_leb128_bench.cc:121:181: warning: extra ‘;’ [-Wpedantic]
      

      Or by both.

      Full log is here:
      http://cv.jenkins.couchbase.com/job/ns-server-simple-test/1496/console

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          pavithra.mahamani Pavithra Mahamani added a comment -

          I believe the failure is most likely because of a warning in unsigned_leb128_bench.cc:121 and not the xdcr test:

          http://cv.jenkins.couchbase.com/job/ns-server-simple-test/1496/warnings28Result/new/

          [WARNINGS] Plug-in Result: Failed - <a href="warningsResult">1 warning</a> exceeds the threshold of 0 by 1
          14:24:47 Build step '[Deprecated] Scan for compiler warnings' changed build result to FAILURE

          artem Artem Stemkovski added a comment - - edited

          Pavithra Mahamani Does it mean that this error is benign and must be in the log:

          ERROR: suite_tearDown (unittest.loader._FailedTest)
          14:24:46 ----------------------------------------------------------------------
          14:24:46 AttributeError: type object 'unidirectional' has no attribute 'suite_tearDown'
          

          Artem Stemkovski, yes, it is benign. This run passed in spite of the same xdcr test error: http://cv.jenkins.couchbase.com/job/ns-server-simple-test/1495/console
          There was some discussion about why it is flagged as an error..I will follow up on what the conclusion was.

          artem Artem Stemkovski added a comment -

          Then it's this change:
          http://review.couchbase.org/c/kv_engine/+/130892

          Due to this warning:

          13:49:26 /home/couchbase/jenkins/workspace/ns-server-simple-test/kv_engine/tests/unsigned_leb128/unsigned_leb128_bench.cc:121:181: warning: extra ‘;’ [-Wpedantic]
          

          jwalker Jim Walker added a comment -

          Why a compiler warning causing a test failure is very odd.

          But that warning has been fixed http://review.couchbase.org/c/kv_engine/+/131149


            People

            Assignee:
            artem Artem Stemkovski
            Reporter:
            artem Artem Stemkovski
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty