Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-43424

Giving users/groups roles via UI aren't being saved and/or aren't appearing

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 7.0.0-Beta1
    • 7.0.0
    • UI
    • Enterprise Edition 7.0.0 build 3739 (beta), Windows, Chrome browser
    • Untriaged
    • 1
    • Unknown

    Description

      Summary: After creating a role or group and assigning it one or more permissions via the UI, the permissions do not show up in the list view or detail view

      Repro:

      1. In UI, go to "Security"
      2. Click "Add User" or "Add Group".
      3. Enter user information
      4. In "Roles" are on right side, select one or more roles.
      5. Click "Add User" or "Add Group" to save.

      Expected:

      The selected roles to be saved to that user. The selected roles should appear in the list view. The selected roles should also appear when going back in to edit that user.

      Actual:

      The selected roles are not appearing in the list view. The selected roles are not appearing in the edit detail view. Based on a REST request, it doesn't appear that the assigned roles are actually being saved at all.

      Notes:

      See attached screenshots.

      Attachments

        1. addgroup1.png
          addgroup1.png
          26 kB
        2. addgroup2.png
          addgroup2.png
          49 kB
        3. adduser1.png
          adduser1.png
          30 kB
        4. adduser2.png
          adduser2.png
          54 kB
        5. adduser3.png
          adduser3.png
          40 kB
        6. getusersRest.png
          getusersRest.png
          33 kB
        7. image-2021-03-18-16-23-02-506.png
          image-2021-03-18-16-23-02-506.png
          28 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          ianmccloy Ian McCloy added a comment -

          When you select the bucket or scope or collection from the dropdown, you also have to click on "add".  This caught me out a few times, there's probably a UX improvement needed. 

          ianmccloy Ian McCloy added a comment - When you select the bucket or scope or collection from the dropdown, you also have to click on "add".  This caught me out a few times, there's probably a UX improvement needed. 

          Got it. Maybe a warning at least something like "you didn't click add are you sure you want to close"?

          matthew.groves Matthew Groves added a comment - Got it. Maybe a warning at least something like "you didn't click add are you sure you want to close"?
          rob.ashcom Rob Ashcom added a comment -

          The UI has been improved somewhat. Try the latest code. Re-open if we still haven't achieved satisfaction.

          rob.ashcom Rob Ashcom added a comment - The UI has been improved somewhat. Try the latest code. Re-open if we still haven't achieved satisfaction.
          pierre.regazzoni Pierre Regazzoni added a comment - - edited

          Verified on 7.0.0-4678

          pierre.regazzoni Pierre Regazzoni added a comment - - edited Verified on 7.0.0-4678

          People

            pierre.regazzoni Pierre Regazzoni
            matthew.groves Matthew Groves
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty