Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-45896

[UI][windows] stack: TypeError: Cannot read property 'quotaUsedPerNode' of undefined - error observed in logs during upgrade testing

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • Cheshire-Cat
    • 7.0.0
    • ns_server
    • Untriaged
    • 1
    • No

    Description

      Steps to repro :
      1. Setup a 2-node cluster running 6.6.2-9588 with kv+n1ql+index+fts services on both nodes
      2. Install the sample buckets and create FTS indexes
      3. Swap rebalance node2 with a spare node running 7.0.0-5016.
      4. Cluster will be in mixed mode

      Following observed in logs:

      Client-side error-report for user "Administrator" on node 'ns_1@172.23.107.126':
      User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
      Got unhandled javascript error:
      name: TypeError;
      message: Cannot read property 'quotaUsedPerNode' of undefined;
      stack: TypeError: Cannot read property 'quotaUsedPerNode' of undefined
      at updateBarChartData (http://172.23.107.126:8091/ui/app.min.js:366:298)
      at Scope.$digest (http://172.23.107.126:8091/ui/libs/angular.js:18380:23)
      at Scope.$apply (http://172.23.107.126:8091/ui/libs/angular.js:18649:24)
      at done (http://172.23.107.126:8091/ui/libs/angular.js:12627:47)
      at completeRequest (http://172.23.107.126:8091/ui/libs/angular.js:12871:7)
      at XMLHttpRequest.requestLoaded (http://172.23.107.126:8091/ui/libs/angular.js:12788:9);
      (repeated 2 times, last seen 13.883025 secs ago)
      

      Logs:
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/mixed_mode_cluster_add_new_node/collectinfo-2021-04-23T230138-ns_1%40172.23.107.126.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/mixed_mode_cluster_add_new_node/collectinfo-2021-04-23T230138-ns_1%40172.23.107.129.zip
      https://cb-jira.s3.us-east-2.amazonaws.com/logs/mixed_mode_cluster_add_new_node/collectinfo-2021-04-23T230138-ns_1%40172.23.107.142.zip

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          This is known issue. I guess, it is incorrect that storageTotals.ram can be undefined.

          There is a similar issue (when there is no kv node in the cluster) that can be reproduced as follows:

          1. setup kv node

          2. add node with non kv services

          3. add one more kv node

          4. remove node #1

          5. shutdown node #3

          storageTotals.ram and storageTotals.hdd will be undefined in this case. I will prepare UI to the undefined ram and hdd values, however, it might be worth to take a look why ram and hdd are undefined in Arun's case.

          CC Meni Hillel

           

           

          pavel Pavel Blagodov added a comment - This is known issue. I guess, it is incorrect that storageTotals.ram can be undefined. There is a similar issue (when there is no kv node in the cluster) that can be reproduced as follows: 1. setup kv node 2. add node with non kv services 3. add one more kv node 4. remove node #1 5. shutdown node #3 storageTotals.ram and storageTotals.hdd will be undefined in this case. I will prepare UI to the undefined ram and hdd values, however, it might be worth to take a look why ram and hdd are undefined in Arun's case. CC  Meni Hillel    

          Build couchbase-server-7.0.0-5053 contains ns_server commit f7d3dd4 with commit message:
          MB-45896: prepare UI to empty storageTotals ram and hdd

          build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-5053 contains ns_server commit f7d3dd4 with commit message: MB-45896 : prepare UI to empty storageTotals ram and hdd

          Build couchbase-server-7.0.0-5055 contains ns_server commit 502e3f8 with commit message:
          MB-45896: check for bucket details

          build-team Couchbase Build Team added a comment - Build couchbase-server-7.0.0-5055 contains ns_server commit 502e3f8 with commit message: MB-45896 : check for bucket details

          Arunkumar Senthilnathan Do you see this error again and again when the node has started? Or is it rather something that happened only once during the node startup (or immediately after the start)?
          I'm asking because the storage info is based on the node info that is periodically collected from all the nodes, so it is possible that during start there is a short period of time when this info is not available yet. This is not perfect, but it will appear a few seconds later. Shouldn't be a problem as it's not critical I think.

          On the other hand if you see that storage info is missing when everything has started, then it's a bug.

          I checked the logs and don't see anything criminal there. I also tried to reproduce it locally, it worked well. It might be something windows specific, though.

          Pavel Blagodov What you described is different thing: storage info is available on kv nodes only, so if you stop all kv nodes it will disappear. I think Arun hit another issue.

          Anyway, I'm going to resolve this issue as Pavel fixed the crash in the UI. Arun, please reopen if you think the bug is there.

          timofey.barmin Timofey Barmin added a comment - Arunkumar Senthilnathan Do you see this error again and again when the node has started? Or is it rather something that happened only once during the node startup (or immediately after the start)? I'm asking because the storage info is based on the node info that is periodically collected from all the nodes, so it is possible that during start there is a short period of time when this info is not available yet. This is not perfect, but it will appear a few seconds later. Shouldn't be a problem as it's not critical I think. On the other hand if you see that storage info is missing when everything has started, then it's a bug. I checked the logs and don't see anything criminal there. I also tried to reproduce it locally, it worked well. It might be something windows specific, though. Pavel Blagodov What you described is different thing: storage info is available on kv nodes only, so if you stop all kv nodes it will disappear. I think Arun hit another issue. Anyway, I'm going to resolve this issue as Pavel fixed the crash in the UI. Arun, please reopen if you think the bug is there.

          Timofey Barmin this was observed only once - closing this - will reopen if it occurs again

          arunkumar Arunkumar Senthilnathan added a comment - Timofey Barmin this was observed only once - closing this - will reopen if it occurs again

          People

            arunkumar Arunkumar Senthilnathan
            arunkumar Arunkumar Senthilnathan
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty