Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-47124

Remove unused XDCR audit events

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 7.0.0
    • 7.1.0
    • ns_server
    • None
    • 1

    Description

      https://docs.couchbase.com/server/current/audit-event-reference/audit-event-reference.html

      XDCR Pause and XDCR Resume actions should be audited but are missing.

      Attachments

        Issue Links

          For Gerrit Dashboard: MB-47124
          # Subject Branch Project Status CR V

          Activity

            Repurposing this ticket to remove the unused audit events.

            steve.watanabe Steve Watanabe added a comment - Repurposing this ticket to remove the unused audit events.

            I opened DOC-8866 to have these removed from the "Audit Event Reference" documentation.

            steve.watanabe Steve Watanabe added a comment - I opened  DOC-8866 to have these removed from the "Audit Event Reference" documentation.

            Build couchbase-server-7.1.0-1086 contains ns_server commit 7b1fc8b with commit message:
            MB-47124 Remove unused XDCR audit events

            build-team Couchbase Build Team added a comment - Build couchbase-server-7.1.0-1086 contains ns_server commit 7b1fc8b with commit message: MB-47124 Remove unused XDCR audit events
            hyun-ju.vega Hyun-Ju Vega added a comment - - edited

            Ian McCloy Lilei Chen

            Just FYI – I opened DOC-9143 to go with DOC-8866 that Steve Watanabe opened.

            Both DOC-8866 and DOC-9143 refers to this documentation page - https://docs.couchbase.com/server/current/audit-event-reference/audit-event-reference.html

            DOC-8866 is about removing audit events 8213-8219 from the doc, since they no longer exist, and DOC-9143 is about adding existing xdcr audit events 16384-16396 to the doc (these exist – https://github.com/couchbase/goxdcr/blob/master/etc/audit_descriptor.json – but are not currently documented). 

            hyun-ju.vega Hyun-Ju Vega added a comment - - edited Ian McCloy Lilei Chen Just FYI – I opened DOC-9143 to go with DOC-8866 that Steve Watanabe opened. Both  DOC-8866  and  DOC-9143  refers to this documentation page -  https://docs.couchbase.com/server/current/audit-event-reference/audit-event-reference.html DOC-8866  is about removing audit events 8213-8219 from the doc, since they no longer exist, and  DOC-9143  is about adding existing xdcr audit events 16384-16396 to the doc (these exist –  https://github.com/couchbase/goxdcr/blob/master/etc/audit_descriptor.json – but are not currently documented). 

            Covered in regression suite.

            pavithra.mahamani Pavithra Mahamani added a comment - Covered in regression suite.

            People

              pavithra.mahamani Pavithra Mahamani
              ianmccloy Ian McCloy
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty