Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-48259

golang revert causing many n1ql regression

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 7.0.2
    • Fix Version/s: None
    • Component/s: query, secondary-index
    • Labels:
    • Triage:
      Untriaged
    • Story Points:
      1
    • Is this a Regression?:
      Unknown

      Description

      Regressions are seen across the board for n1ql tests that are index heavy.

      6589 - http://perf.jenkins.couchbase.com/job/arke-multi-client/5196/ - 75.0
      6588 - http://perf.jenkins.couchbase.com/job/arke-multi-client/5195/ - 89.0

      http://changelog.build.couchbase.com/?product=couchbase-server&fromVersion=7.0.2&fromBuild=6588&toVersion=7.0.2&toBuild=6589&f_indexing=on&f_product-metadata=off

      • Commit: 53bda0e7649344f133bb74a6774e4999323f0155 in build: couchbase-server-7.0.2-6589
        Revert "MB-44731 [BP to 7.0.1] Move indexer and projector go-runtime to version 1.16.5" This reverts commit 88d90428281a068db6dc3c952680f97a3af569c9. Original commit was done for MB-46323. Reverting the golang upgrade due to the issues seen in MB-44731 and MB-47600. Change-Id: Ibc8c0688d30a701cf0330277eb2c290465fa37c2
        Author: Deepkaran Salooja <deepkaran@couchbase.com>
        Committer: Deepkaran Salooja <deepkaran@couchbase.com>
         
        Looks like golang revert is source of the regression

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

            deepkaran.salooja Deepkaran Salooja added a comment -

            Korrigan Clark, could you please check if the performance numbers are within the same ballpark as 7.0.0GA build? The golang revert had to be done due to the issues listed in MB-48189. The upgrade is still in place for Neo.

            korrigan.clark Korrigan Clark added a comment -

            Deepkaran Salooja performance is in the same ballpark as 7.0 ga

            deepkaran.salooja Deepkaran Salooja added a comment -

            Thanks Korrigan Clark, as there is no perf regression wrt 7.0 GA, I'll be resolving this ticket. 


              People

              Assignee:
              korrigan.clark Korrigan Clark
              Reporter:
              korrigan.clark Korrigan Clark
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes

                    PagerDuty