Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-48526

restore fails with corrupted directory error

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Duplicate
    • Neo
    • None
    • tools
    • Untriaged
    • 1
    • Unknown

    Description

      In a couple perf tests we restore a backup called soe10M. When the backup command is run we get an error: 
      Error restoring cluster: Backup repository is corrupted 'ranges' directory is not in the correct format
      command: 

      /opt/couchbase/bin/cbbackupmgr restore --archive /backups --repo soe10M --threads 24 --cluster http://localhost:8091 --username Administrator --password password --disable-ft-indexes --disable-gsi-indexes

      job:

      http://perf.jenkins.couchbase.com/job/hebe/9079/console

      build 7.0.2-6683

      I dont see a directory called ranges:

      [root@172-23-100-204 backups]# ls 
      lock.lk  logs  soe10M 
      [root@172-23-100-204 backups]# cd soe10M/ 
      [root@172-23-100-204 soe10M]# ls 
      2020-02-12T11_32_11.87436689-08_00  backup-meta.json 
      [root@172-23-100-204 soe10M]# cat backup-meta.json 
      {   "exclude_buckets": [],   "include_buckets": [],   "exclude_collections": [],   "include_collections": [],   "filter_keys": "",   "filter_values": "",   "disable_cluster_config": true,   "disable_bucket_config": false,   "disable_views": false,   "disable_gsi_indexes": false,   "disable_queries": true,   "disable_ft_indexes": false,   "disable_data": false,   "disable_eventing": false,   "allow_bucket_creation": false,   "filter_vbuckets": {     "list": [],     "enabled": false   } }
      [root@172-23-100-204 soe10M]# cd 2020-02-12T11_32_11.87436689-08_00/ 
      [root@172-23-100-204 2020-02-12T11_32_11.87436689-08_00]# ls 
      bucket-1-e3bc22308e6ff0551d2e36217daddbf7  
      events.json  plan.json 
      [root@172-23-100-204 2020-02-12T11_32_11.87436689-08_00]# cd bucket-1-e3bc22308e6ff0551d2e36217daddbf7/ 
      [root@172-23-100-204 bucket-1-e3bc22308e6ff0551d2e36217daddbf7]# ls 
      bucket-config.json  data  full-text.json  gsi.json  range.json  views.json
      

      There is a json called range though

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            james.lee James Lee added a comment -

            Hi Korrigan Clark,

            Marking this as a duplicate of MB-48338, this will happen when mixing and matching 'cbbackupmgr' versions against the same archive.

            Versions 7.1.0-1237-7.1.0-1288 will create, but not remove a directory called '.restore' at the archive level (wasn't showing for your 'ls' since it's a dotfile). Versions past 7.1.0-1288 will only leave this directory in the result of an error.

            I've ssh'd into the machine, removed the '.restore' directory and kicked of a rebuild (once I've confirmed it works as expected, I'll rebuild the failed jobs).

            Thanks,
            James

            james.lee James Lee added a comment - Hi Korrigan Clark , Marking this as a duplicate of MB-48338 , this will happen when mixing and matching ' cbbackupmgr ' versions against the same archive. Versions 7.1.0-1237-7.1.0-1288 will create, but not remove a directory called ' .restore ' at the archive level (wasn't showing for your ' ls ' since it's a dotfile). Versions past 7.1.0-1288 will only leave this directory in the result of an error. I've ssh'd into the machine, removed the ' .restore ' directory and kicked of a rebuild (once I've confirmed it works as expected, I'll rebuild the failed jobs). Thanks, James
            james.lee James Lee added a comment -

            To confirm, the restore is now proceeding as expected; I'll kick of the other jobs.

            O/T Korrigan Clark it might be worth adding the '--no-progress-bar' flag when running 'cbbackpmgr' it looks like we're generating a lot of unnecessary data which is being stored in Jenkins, example below.

            Progress Report

            09:13:55 [172.23.100.204] out: Restoring backup '2020-02-12T11_32_11.87436689-08_00'
            09:13:55 [172.23.100.204] out: Transferring k... at 68.43MiB/s (about 4m26s remaining) 14070863 items / 9.37GiB
            09:13:55 [172.23.100.204] out: [========================                                               ] 34.27%
            

            james.lee James Lee added a comment - To confirm, the restore is now proceeding as expected; I'll kick of the other jobs. O/T Korrigan Clark it might be worth adding the ' --no-progress-bar ' flag when running ' cbbackpmgr ' it looks like we're generating a lot of unnecessary data which is being stored in Jenkins, example below. Progress Report 09:13:55 [172.23.100.204] out: Restoring backup '2020-02-12T11_32_11.87436689-08_00' 09:13:55 [172.23.100.204] out: Transferring k... at 68.43MiB/s (about 4m26s remaining) 14070863 items / 9.37GiB 09:13:55 [172.23.100.204] out: [======================== ] 34.27%

            People

              korrigan.clark Korrigan Clark
              korrigan.clark Korrigan Clark
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty