Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-48763

Avg. initial XDCR rate with Adv Filter dropped on build 7.1.0-1250

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 7.1.0
    • 7.1.0
    • XDCR
    • Untriaged
    • 1
    • Yes

    Description

       

      Avg. initial XDCR rate with adv filter dropped by 50% on build 7.1.0-1250.

      Avg. initial XDCR rate (items/sec), 1 -> 1 (2 source nozzles, 4 target nozzles), 1 bucket x 100M x 1KB, Adv Filter, Array match (~100% of the items)

      Build

      Avg. initial XDCR rate

       Job
      7.1.0-1085 128,634  http://perf.jenkins.couchbase.com/job/titan/11574/ 
      7.1.0-1250 64,306  http://perf.jenkins.couchbase.com/job/titan/12058/

      Avg. initial XDCR rate (items/sec), 1 -> 1 (2 source nozzles, 4 target nozzles), 1 bucket x 100M x 1KB, Adv Filter, matching body (~100% of the items)

      Build

      Avg. initial XDCR rate

      Job
      7.1.0-1085 137,705 http://perf.jenkins.couchbase.com/job/titan/11575/
      7.1.0-1250 69,357 http://perf.jenkins.couchbase.com/job/titan/12059/

      Avg. initial XDCR rate (items/sec), 1 -> 1 (2 source nozzles, 4 target nozzles), 1 bucket x 100M x 1KB, Adv Filter, matching xattr (~100% of the items)

      Build

      Avg. initial XDCR rate

      Job
      7.1.0-1085 132,290 http://perf.jenkins.couchbase.com/job/titan/11576/
      7.1.0-1250 68,308 http://perf.jenkins.couchbase.com/job/titan/12060/

      Avg. initial XDCR rate (items/sec), 1 -> 1 (2 source nozzles, 4 target nozzles), 1 bucket x 100M x 1KB, Adv Filter, matching xattr, compression active

       

      Build

      Avg. initial XDCR rate

      Job
      7.1.0-1085 128,018 http://perf.jenkins.couchbase.com/job/titan/11577/
      7.1.0-1250 69,533 http://perf.jenkins.couchbase.com/job/titan/12061/

       

       

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            neil.huang Neil Huang added a comment -

            Bo-Chun Wang - thanks for the test run... but the run does not include CPU profile capture. Can you please re-run the test with golang profile capture so I can look into it?
            Thanks.

            neil.huang Neil Huang added a comment - Bo-Chun Wang - thanks for the test run... but the run does not include CPU profile capture. Can you please re-run the test with golang profile capture so I can look into it? Thanks.
            bo-chun.wang Bo-Chun Wang added a comment -

            I have done a run and captured golang profile.

            http://perf.jenkins.couchbase.com/job/titan-xdcr-dev/55/ 

            bo-chun.wang Bo-Chun Wang added a comment - I have done a run and captured golang profile. http://perf.jenkins.couchbase.com/job/titan-xdcr-dev/55/  
            neil.huang Neil Huang added a comment -

            Thanks for the CPU profile. It seems to have been caused by MB-47813. Snappy.Encode() is being called without discretion.

            I think there can be an optimization such that this is not needed. Will update.

            neil.huang Neil Huang added a comment - Thanks for the CPU profile. It seems to have been caused by MB-47813 . Snappy.Encode() is being called without discretion. I think there can be an optimization such that this is not needed. Will update.
            neil.huang Neil Huang added a comment -

            Build couchbase-server-7.1.0-1507 contains goxdcr commit ca578a6 with commit message:
            MB-48902 - if transactional xattr was not stripped, use original compressed body

            neil.huang Neil Huang added a comment - Build couchbase-server-7.1.0-1507 contains goxdcr commit  ca578a6  with commit message: MB-48902  - if transactional xattr was not stripped, use original compressed body
            bo-chun.wang Bo-Chun Wang added a comment -

            The performance is back. I close this issue.

            bo-chun.wang Bo-Chun Wang added a comment - The performance is back. I close this issue.

            People

              bo-chun.wang Bo-Chun Wang
              bo-chun.wang Bo-Chun Wang
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty