Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-49544

Performance : Panic observed concurrent map read and map write

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Duplicate
    • Neo
    • Neo
    • eventing

    Description

      Build: 7.1.0-1695 , not seen on 7.1.0-1650

      fatal error: concurrent map read and map write
       
       
      goroutine 7119 [running]:
      runtime.throw(0xfe6b76, 0x21)
      	/home/couchbase/.cbdepscache/exploded/x86_64/go-1.13.7/go/src/runtime/panic.go:774 +0x72 fp=0xc006287b58 sp=0xc006287b28 pc=0x432f22
      runtime.mapaccess2(0xe538a0, 0xc003499320, 0xc006287bd6, 0xc006287c68, 0x5)
      	/home/couchbase/.cbdepscache/exploded/x86_64/go-1.13.7/go/src/runtime/map.go:470 +0x278 fp=0xc006287ba0 sp=0xc006287b58 pc=0x411968
      github.com/couchbase/eventing/consumer.(*Consumer).checkIfAlreadyEnqueued(0xc005a7b200, 0xc00349008f, 0xc006287d00)
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/eventing/consumer/util.go:20 +0xd1 fp=0xc006287d18 sp=0xc006287ba0 pc=0xc6b021
      github.com/couchbase/eventing/consumer.(*Consumer).vbsStateUpdate.func2(0xfdc483, 0x18, 0xc005a7b200, 0x2, 0xc0004dd800, 0x6d, 0x80, 0xc006dd8d90)
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/eventing/consumer/vbucket_takeover.go:156 +0x46e fp=0xc006287fa0 sp=0xc006287d18 pc=0xca0a9e
      runtime.goexit()
      	/home/couchbase/.cbdepscache/exploded/x86_64/go-1.13.7/go/src/runtime/asm_amd64.s:1357 +0x1 fp=0xc006287fa8 sp=0xc006287fa0 pc=0x462cc1
      created by github.com/couchbase/eventing/consumer.(*Consumer).vbsStateUpdate
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/eventing/consumer/vbucket_takeover.go:127 +0xb6d
       
       
      goroutine 1 [chan receive, 1 minutes]:
      github.com/couchbase/eventing/supervisor.(*SuperSupervisor).HandleSupCmdMsg(0xc0004fbb80)
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/eventing/supervisor/super_supervisor.go:805 +0x73
      main.main()
      	goproj/src/github.com/couchbase/eventing/cmd/producer/main.go:110 +0x432
       
       
      goroutine 19 [select, 2 minutes]:
      github.com/couchbase/cbauth/cbauthimpl.(*tlsNotifier).loop(0xc00013e220)
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/cbauth/cbauthimpl/impl.go:382 +0xa3
      created by github.com/couchbase/cbauth/cbauthimpl.NewSVCForTest
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/cbauth/cbauthimpl/impl.go:539 +0x269
       
       
      goroutine 20 [select, 1 minutes]:
      github.com/couchbase/cbauth/cbauthimpl.(*cfgChangeNotifier).loop(0xc00013e240)
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/cbauth/cbauthimpl/impl.go:302 +0xb7
      created by github.com/couchbase/cbauth/cbauthimpl.NewSVCForTest
      	/home/couchbase/jenkins/workspace/couchbase-server-unix/goproj/src/github.com/couchbase/cbauth/cbauthimpl/impl.go:540 +0x292 

      Job link : 

      http://perf.jenkins.couchbase.com/job/themis/13569/console

       

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            Ankit Prabhu Likely a duplicate

            jeelan.poola Jeelan Poola added a comment - Ankit Prabhu Likely a duplicate

            Duplicate of  MB-49510. Fixed in build Build couchbase-server-7.1.0-1697

            ankit.prabhu Ankit Prabhu added a comment - Duplicate of   MB-49510 . Fixed in build Build couchbase-server-7.1.0-1697

            Closing all Duplicates, Not a Bug, Incomplete, Duplicate

            ritam.sharma Ritam Sharma added a comment - Closing all Duplicates, Not a Bug, Incomplete, Duplicate

            People

              vikas.chaudhary Vikas Chaudhary
              vikas.chaudhary Vikas Chaudhary
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty