Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-49683

After cluster restart (POST /analytics/cluster/restart): ASX4000: Partition id...already in use

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 7.1.0
    • 7.1.0
    • analytics
    • Untriaged
    • 1
    • Unknown
    • CX Sprint 271

    Description

      Observed on local run of CbRemoteLinksIT, the following failure when two-node cluster (n_0/n_2) restarts:

      2021-11-19T06:43:52.682-08:00 ERRO CBAS.control.AnalyticsDriver [main] Exiting AnalyticsDriver due to exception
      org.apache.hyracks.api.exceptions.HyracksDataException: org.apache.asterix.common.exceptions.AsterixException: ASX4000: Partition id 0 for node f12069b9ea99bb5046fb3f06331faf64 already in use by node 6a367f4500fa42bd0ae0767f3fc0e318
      	at org.apache.hyracks.api.exceptions.HyracksDataException.create(HyracksDataException.java:49) ~[hyracks-api-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.asterix.common.config.AsterixProperties.lambda$registerConfigOptions$0(AsterixProperties.java:47) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.hyracks.control.common.config.ConfigManager.processConfig(ConfigManager.java:229) ~[hyracks-control-common-7.1.0-0000.jar:7.1.0-0000]
      	at com.couchbase.analytics.control.AnalyticsDriver.createNcService(AnalyticsDriver.java:203) ~[cbas-server-7.1.0-0000.jar:7.1.0-0000]
      	at com.couchbase.analytics.control.AnalyticsDriver.initNcService(AnalyticsDriver.java:153) ~[cbas-server-7.1.0-0000.jar:7.1.0-0000]
      	at com.couchbase.analytics.control.AnalyticsDriver.main(AnalyticsDriver.java:77) [cbas-server-7.1.0-0000.jar:7.1.0-0000]
      Caused by: org.apache.asterix.common.exceptions.AsterixException: ASX4000: Partition id 0 for node f12069b9ea99bb5046fb3f06331faf64 already in use by node 6a367f4500fa42bd0ae0767f3fc0e318
      	at org.apache.asterix.common.exceptions.AsterixException.create(AsterixException.java:74) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.asterix.common.config.PropertiesAccessor.configureNc(PropertiesAccessor.java:130) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.asterix.common.config.PropertiesAccessor.<init>(PropertiesAccessor.java:81) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.asterix.common.config.PropertiesAccessor.getInstance(PropertiesAccessor.java:215) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	at org.apache.asterix.common.config.AsterixProperties.lambda$registerConfigOptions$0(AsterixProperties.java:45) ~[asterix-common-7.1.0-0000.jar:7.1.0-0000]
      	... 4 more
      

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            murtadha.hubail Murtadha Hubail added a comment - - edited

            The issue was caused by the use of an undocumented API in our tests. We could probably close this issue.

            murtadha.hubail Murtadha Hubail added a comment - - edited The issue was caused by the use of an undocumented API in our tests. We could probably close this issue.

            People

              michael.blow Michael Blow
              michael.blow Michael Blow
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty