Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-54269

When upgrading locally (CE -> EE) on Mac, isEnterprise flag remains false

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: User Error
    • 7.1.0
    • None
    • installer
    • MacOS Ventura M1 Pro, local installation (not Docker)
    • Untriaged
    • MacOSX 64-bit
    • 1
    • Unknown

    Description

      1. Install CE
      2. Delete CE
      3. Install EE
      4. EE version still has isEnterprise = false

      Features like Index Advisor are not present even though it is clearly EE (version number confirmed in UI)

      To fix, ~/Library/Application Support/Couchbase needs to be deleted.

      See faulty Library directory here: https://drive.google.com/drive/folders/1-O0MN8f-rxxB6nxz4TeDaqy_cj_Q1GMo?usp=sharing

      Output of API Call to /pools:
      curl -u Administrator:couchbase
      http://localhost:8091/pools
      {"isAdminCreds":true,"isROAdminCreds":false,"isEnterprise":false,"allowedServices":["kv","n1ql","index","fts"],"isDeveloperPreview":false,"packageVariant":"macos","pools":[

      {"name":"default","uri":"/pools/default?uuid=5a300a987417c78f5be3c0a51145384f","streamingUri":"/poolsStreaming/default?uuid=5a300a987417c78f5be3c0a51145384f"}

      ],"settings":{"maxParallelIndexers":"/settings/maxParallelIndexers?uuid=5a300a987417c78f5be3c0a51145384f","viewUpdateDaemon":"/settings/viewUpdateDaemon?uuid=5a300a987417c78f5be3c0a51145384f"},"uuid":"5a300a987417c78f5be3c0a51145384f","implementationVersion":"7.1.0-2556-enterprise","componentsVersion":{"asn1":"5.0.17","kernel":"8.1.3","lhttpc":"1.3.0","public_key":"1.11.3","chronicle":"0.0.1","os_mon":"2.7.1","sasl":"4.1","ale":"0.0.0","ssl":"10.5.3","inets":"7.4.2","stdlib":"3.16.1","ns_server":"7.1.0-2556-enterprise","crypto":"5.0.4"}}%

      Attachments

        1. image.png
          image.png
          431 kB
        2. image (1).png
          image (1).png
          11 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          dfinlay Dave Finlay added a comment -

          Aaron - you'll need to follow the complete instructions to uninstall on Mac: https://docs.couchbase.com/server/current/install/install-uninstalling.html#macos.

          dfinlay Dave Finlay added a comment - Aaron - you'll need to follow the complete instructions to uninstall on Mac: https://docs.couchbase.com/server/current/install/install-uninstalling.html#macos .
          ming.ho Ming Ho added a comment -

          Aaron Schneider Please let us know if the issue is resolved after following the uninstall instruction.

          ming.ho Ming Ho added a comment - Aaron Schneider Please let us know if the issue is resolved after following the uninstall instruction.
          ceej Chris Hillery added a comment - - edited

          Resolving as User Error. Can't seem to assign it back to Aaron to verify so I'll just close it. Aaron Schneider if you have additional information to suggest it's a different bug, please re-open.

          ceej Chris Hillery added a comment - - edited Resolving as User Error. Can't seem to assign it back to Aaron to verify so I'll just close it. Aaron Schneider if you have additional information to suggest it's a different bug, please re-open.

          People

            build-team Couchbase Build Team
            aaron.schneider Aaron Schneider
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty