Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1318

.NetCore SDK fails connect to nodes after restart all nodes in async mode on CentOS7

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.4.0
    • 2.4.6
    • None

    Description

      .NetCore SDK fails connecting to nodes after all nodes are restarted.

      This is specifically for .NETCore SDK async mode on CentOS. I could not see this on sync mode on CentOS nor sync/async mode on Windows 2012

       

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris added a comment -

          NCBC-1307 includes improvements for all OS; this ticket is for the CentOS issue exclusively which is not resolved in 2.4.0

          jmorris Jeff Morris added a comment - NCBC-1307 includes improvements for all OS; this ticket is for the CentOS issue exclusively which is not resolved in 2.4.0
          jmorris Jeff Morris added a comment -

          Jae Park [X] - you can assign these back to me if they are still valid issues.

          jmorris Jeff Morris added a comment - Jae Park [X] - you can assign these back to me if they are still valid issues.

          Tested again and there was no operation in rebound phase.

          Attached the test result.

          jaekwon.park Jae Park [X] (Inactive) added a comment - Tested again and there was no operation in rebound phase. Attached the test result.
          jmorris Jeff Morris added a comment -

          I can't replicate on ubuntu.

          jmorris Jeff Morris added a comment - I can't replicate on ubuntu.
          jmorris Jeff Morris added a comment -

          Jae -

          I am reassigning to you so that we can verify that this has not been fixed between 2.4.0 and 2.4.6. If we can verify on next release testing cycle (SDKQE-1032), that would be awesome.

          Thanks,

          Jeff

          jmorris Jeff Morris added a comment - Jae - I am reassigning to you so that we can verify that this has not been fixed between 2.4.0 and 2.4.6. If we can verify on next release testing cycle (SDKQE-1032), that would be awesome. Thanks, Jeff

          Tested with .net sdk 2.4.6 and I confirm that connections are recovered.

          jaekwon.park Jae Park [X] (Inactive) added a comment - Tested with .net sdk 2.4.6 and I confirm that connections are recovered.
          jmorris Jeff Morris added a comment -

          Thanks Jae Park [X]

          jmorris Jeff Morris added a comment - Thanks Jae Park [X]

          People

            jaekwon.park Jae Park [X] (Inactive)
            jmorris Jeff Morris
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty