Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1318

.NetCore SDK fails connect to nodes after restart all nodes in async mode on CentOS7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.4.6
    • Component/s: None
    • Labels:

      Description

      .NetCore SDK fails connecting to nodes after all nodes are restarted.

      This is specifically for .NETCore SDK async mode on CentOS. I could not see this on sync mode on CentOS nor sync/async mode on Windows 2012

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Hide
          jmorris Jeff Morris added a comment -

          NCBC-1307 includes improvements for all OS; this ticket is for the CentOS issue exclusively which is not resolved in 2.4.0

          Show
          jmorris Jeff Morris added a comment - NCBC-1307 includes improvements for all OS; this ticket is for the CentOS issue exclusively which is not resolved in 2.4.0
          Hide
          jmorris Jeff Morris added a comment -

          Jae Park [X] - you can assign these back to me if they are still valid issues.

          Show
          jmorris Jeff Morris added a comment - Jae Park [X] - you can assign these back to me if they are still valid issues.
          Hide
          jaekwon.park Jae Park [X] (Inactive) added a comment -

          Tested again and there was no operation in rebound phase.

          Attached the test result.

          Show
          jaekwon.park Jae Park [X] (Inactive) added a comment - Tested again and there was no operation in rebound phase. Attached the test result.
          Hide
          jmorris Jeff Morris added a comment -

          I can't replicate on ubuntu.

          Show
          jmorris Jeff Morris added a comment - I can't replicate on ubuntu.
          Hide
          jmorris Jeff Morris added a comment -

          Jae -

          I am reassigning to you so that we can verify that this has not been fixed between 2.4.0 and 2.4.6. If we can verify on next release testing cycle (SDKQE-1032), that would be awesome.

          Thanks,

          Jeff

          Show
          jmorris Jeff Morris added a comment - Jae - I am reassigning to you so that we can verify that this has not been fixed between 2.4.0 and 2.4.6. If we can verify on next release testing cycle (SDKQE-1032), that would be awesome. Thanks, Jeff
          Hide
          jaekwon.park Jae Park [X] (Inactive) added a comment -

          Tested with .net sdk 2.4.6 and I confirm that connections are recovered.

          Show
          jaekwon.park Jae Park [X] (Inactive) added a comment - Tested with .net sdk 2.4.6 and I confirm that connections are recovered.
          Hide
          jmorris Jeff Morris added a comment -

          Thanks Jae Park [X]

          Show
          jmorris Jeff Morris added a comment - Thanks Jae Park [X]

            People

            • Assignee:
              jaekwon.park Jae Park [X] (Inactive)
              Reporter:
              jmorris Jeff Morris
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.