Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1396

Opening Memcached buckets has significant delay

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.4.4
    • 2.4.5
    • None
    • None

    Description

      When opening a Memcached bucket there is a long delay before the method returns (local testing showed a 10 second delay). The delay is not observed when opening Couchbase buckets.

      The issue was reported in this forum post

      Attachments

        For Gerrit Dashboard: NCBC-1396
        # Subject Branch Project Status CR V

        Activity

          This can be observed when running integration tests both locally and during jenkins builds.

          mike.goldsmith Michael Goldsmith added a comment - This can be observed when running integration tests both locally and during jenkins builds.
          jmorris Jeff Morris added a comment -

          Michael Goldsmith - the problem is probably related to the fact that the client will try CCCP before switching over to HTTP Streaming (Memcached buckets don't support CCCP). The client doesn't know what kind of bucket we are opening (since OpenBucket(name, pass) doesn't specify Type) - so it first tries with CCCP and then fall back to HTTP Streaming - it will try on each node configured, so this may take a long time if you have several nodes in your config.

          jmorris Jeff Morris added a comment - Michael Goldsmith - the problem is probably related to the fact that the client will try CCCP before switching over to HTTP Streaming (Memcached buckets don't support CCCP). The client doesn't know what kind of bucket we are opening (since OpenBucket(name, pass) doesn't specify Type) - so it first tries with CCCP and then fall back to HTTP Streaming - it will try on each node configured, so this may take a long time if you have several nodes in your config.

          The memcached integration tests were running slower because the cluster reference was being disposed of after each test, where it should only happy after all tests have run.

          mike.goldsmith Michael Goldsmith added a comment - The memcached integration tests were running slower because the cluster reference was being disposed of after each test, where it should only happy after all tests have run.
          mike.goldsmith Michael Goldsmith added a comment - - edited

          Test run dropped from 10+ to 4 minutes

          http://sdkbuilds.sc.couchbase.com/job/cv-netclient/640/ 

          mike.goldsmith Michael Goldsmith added a comment - - edited Test run dropped from 10+ to 4 minutes http://sdkbuilds.sc.couchbase.com/job/cv-netclient/640/  

          People

            mike.goldsmith Michael Goldsmith
            mike.goldsmith Michael Goldsmith
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty