Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-1746

QueryAsync times out after 75 seconds, even with extended timeout values

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.6.0, 2.6.1
    • Fix Version/s: 2.7.0
    • Component/s: None
    • Labels:
      None

      Description

      Raised via this forum post: https://forums.couchbase.com/t/cant-extend-query-timeout-in-c-sdk/17730

      Initial error:

      "System.IO.IOException: Unable to read data from the transport connection: The I/O operation has been aborted because of either a thread exit or an application request. ---> System.Net.Sockets.SocketException: The I/O operation has been aborted because of either a thread exit or an application request"

      Sync version works, async version times out after approx 75 seconds.

      May be related to how task cancellation tokens are managed for async queries.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          jmorris Jeff Morris added a comment - - edited

          Moving this to 2.6.3 - so far I cannot replicate. It could be specific to the user's configuration. Need more info.


            People

            • Assignee:
              jmorris Jeff Morris
              Reporter:
              mike.goldsmith Michael Goldsmith
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes

                  PagerDuty

                  Error rendering 'com.pagerduty.jira-server-plugin:PagerDuty'. Please contact your Jira administrators.