Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-244

Explicit docs for what .NET Framework versions are supported

    Details

      Description

      Need to be explicit about what versions of Visual Studio are supported, and what .NET Framework is supported. 3.5? 4.0?

      The docs mention that you need the full .NET Framework, not just a Client profile. But don't mention if 4.0 is needed. It seems that 3.5 is not supported, but I'm not positive.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        TimSmith Tim Smith (Inactive) added a comment -

        I just got this update:

        The 1.2 versions use 4.0 features for some things. 3.5 will still work with the 1.1 series (1.2 series is recommended, has important stability fixes).

        Show
        TimSmith Tim Smith (Inactive) added a comment - I just got this update: The 1.2 versions use 4.0 features for some things. 3.5 will still work with the 1.1 series (1.2 series is recommended, has important stability fixes).
        Hide
        TimSmith Tim Smith (Inactive) added a comment -

        Probably need to confirm this info, and decide if we want to just state plainly that 4.0 features are used in the .NET SDK. Probably need input from SDK dev team on this.

        Tim

        Show
        TimSmith Tim Smith (Inactive) added a comment - Probably need to confirm this info, and decide if we want to just state plainly that 4.0 features are used in the .NET SDK. Probably need input from SDK dev team on this. Tim
        Hide
        john John Zablocki (Inactive) added a comment -

        The release note for 1.2 GA does announce the 4.0 requirement - http://www.couchbase.com/docs/couchbase-sdk-net-1.2/couchbase-sdk-net-rn_1-2-0g.html. But agree, it could be added to the getting started. 3.5 support will be targeted for the May release.

        Show
        john John Zablocki (Inactive) added a comment - The release note for 1.2 GA does announce the 4.0 requirement - http://www.couchbase.com/docs/couchbase-sdk-net-1.2/couchbase-sdk-net-rn_1-2-0g.html . But agree, it could be added to the getting started. 3.5 support will be targeted for the May release.
        Hide
        ingenthr Matt Ingenthron added a comment -

        Todd: can you verify this on the docs and close?

        Show
        ingenthr Matt Ingenthron added a comment - Todd: can you verify this on the docs and close?

          People

          • Assignee:
            tgreenstein Todd Greenstein
            Reporter:
            TimSmith Tim Smith (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:

              Gerrit Reviews

              There are no open Gerrit changes