Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2454

EndPoint may be null during SendAsync

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Fixed
    • 3.0.0
    • 3.0.1
    • library
    • None
    • 1

    Description

      During GetAsync, endPoint was observed to be null though it's asserted as not null.

      [04/01/2020 12:05:47] warn: xxx.Service.DataService[0]
            Error getting document key XXXXXXXXXXXXX from default collection: Value cannot be null. (Parameter 'endPoint')
      ====>ErrorMsg: System.AggregateException: One or more errors occurred. (Value cannot be null. (Parameter 'endPoint'))
             ---> System.ArgumentNullException: Value cannot be null. (Parameter 'endPoint')
               at Couchbase.CouchbaseBucket.SendAsync(IOperation op, CancellationToken token, Nullable`1 timeout)
               at Couchbase.Core.Retry.RetryOrchestrator.RetryAsync(BucketBase bucket, IOperation operation, CancellationToken token, Nullable`1 timeout)
               at Couchbase.KeyValue.CouchbaseCollection.ExecuteLookupIn(String id, IEnumerable`1 specs, LookupInOptions options)
               at Couchbase.KeyValue.CouchbaseCollection.GetAsync(String id, GetOptions options)
      

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            I have fixed the root cause of this issue and have filed a new issue to resolve the incorrect assumption with the use of endPoint.

            brett19 Brett Lawson added a comment - I have fixed the root cause of this issue and have filed a new issue to resolve the incorrect assumption with the use of endPoint.

            People

              brett19 Brett Lawson
              ingenthr Matt Ingenthron
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes

                  PagerDuty