Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2624

"Not connected to any bucket" / NO_BUCKET error on insert

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.7.19
    • 2.7.20
    • library
    • windows / .net core 3.1

      Couchbase Server Enterprise Edition 6.5.1 build 6299
    • 1

    Description

      Summary: When trying to insert data into a bucket, operations fails (when using 2.7.19)

      Repro:

      1. See attached code for barebones example.
      2. Debug to bucket.Insert
      3. View response.Success

      Expected:

      response.Success is true, and document is inserted.

      Actual:

      response.Success is false.

      document is not inserted

      message is KV Error: {Name="NO_BUCKET", Description="Not connected to any bucket", Attributes="conn-state-invalidated"}

      Notes:

      I tried the exact same code with 2.7.18, and it works as expected.

      Log output is attached. Code attached.

       

      Attachments

        1. logs.txt
          42 kB
        2. nlog.config
          1.0 kB
        3. Program.cs
          2 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          That's odd. It obviously wouldn't have gotten past any testing if this is the case. It was tested before release.

          ingenthr Matt Ingenthron added a comment - That's odd. It obviously wouldn't have gotten past any testing if this is the case. It was tested before release.
          jmorris Jeff Morris added a comment -

          I confirmed - its a bug, not sure how this would have made it through siti testing? I am going to de-list on NuGet to contain the issue.

          jmorris Jeff Morris added a comment - I confirmed - its a bug, not sure how this would have made it through siti testing? I am going to de-list on NuGet to contain the issue.
          jmorris Jeff Morris added a comment -

          2020/08/05 11:39:17.299|DEBUG|Bootstrapping with 10.143.200.101:11210 failed. |Couchbase.Configuration.Server.Providers.ConfigProviderBase|
          2020/08/05 11:39:17.299|WARN| Value cannot be null. (Parameter 'key')|Couchbase.Configuration.Server.Providers.ConfigProviderBase|
          2020/08/05 11:39:17.343|WARN| NodeLocator is not defined|Couchbase.Core.ClusterController|

          jmorris Jeff Morris added a comment - 2020/08/05 11:39:17.299|DEBUG|Bootstrapping with 10.143.200.101:11210 failed. |Couchbase.Configuration.Server.Providers.ConfigProviderBase| 2020/08/05 11:39:17.299|WARN| Value cannot be null. (Parameter 'key')|Couchbase.Configuration.Server.Providers.ConfigProviderBase| 2020/08/05 11:39:17.343|WARN| NodeLocator is not defined|Couchbase.Core.ClusterController|
          jmorris Jeff Morris added a comment - - edited
          1. The global config is being fetched and the bucket name is empty
          2. SDK2 only expects a bucket config so the name field is null because of 1
          3. Null name causes an exception because its used as key in a dictionary

           
          {"rev":17623,"nodesExt":[{"services":{"mgmt":8091,"mgmtSSL":18091,"indexAdmin":9100,"indexScan":9101,"indexHttp":9102,"indexStreamInit":9103,"indexStreamCatchup":9104,"indexStreamMaint":9105,"indexHttps":19102,"kv":11210,"kvSSL":11207,"capi":8092,"capiSSL":18092,"projector":9999,"projector":9999,"n1ql":8093,"n1qlSSL":18093},"thisNode":true,"hostname":"10.143.200.101"},{"services":{"mgmt":8091,"mgmtSSL":18091,"indexAdmin":9100,"indexScan":9101,"indexHttp":9102,"indexStreamInit":9103,"indexStreamCatchup":9104,"indexStreamMaint":9105,"indexHttps":19102,"kv":11210,"kvSSL":11207,"capi":8092,"capiSSL":18092,"projector":9999,"projector":9999,"n1ql":8093,"n1qlSSL":18093},"hostname":"10.143.200.102"},{"services":{"mgmt":8091,"mgmtSSL":18091,"indexAdmin":9100,"indexScan":9101,"indexHttp":9102,"indexStreamInit":9103,"indexStreamCatchup":9104,"indexStreamMaint":9105,"indexHttps":19102,"kv":11210,"kvSSL":11207,"capi":8092,"capiSSL":18092,"projector":9999,"projector":9999,"n1ql":8093,"n1qlSSL":18093},"hostname":"10.143.200.103"}],"clusterCapabilitiesVer":[1,0],"clusterCapabilities":{"n1ql":["enhancedPreparedStatements"]}} 

          jmorris Jeff Morris added a comment - - edited The global config is being fetched and the bucket name is empty SDK2 only expects a bucket config so the name field is null because of 1 Null name causes an exception because its used as key in a dictionary   { "rev" : 17623 , "nodesExt" :[{ "services" :{ "mgmt" : 8091 , "mgmtSSL" : 18091 , "indexAdmin" : 9100 , "indexScan" : 9101 , "indexHttp" : 9102 , "indexStreamInit" : 9103 , "indexStreamCatchup" : 9104 , "indexStreamMaint" : 9105 , "indexHttps" : 19102 , "kv" : 11210 , "kvSSL" : 11207 , "capi" : 8092 , "capiSSL" : 18092 , "projector" : 9999 , "projector" : 9999 , "n1ql" : 8093 , "n1qlSSL" : 18093 }, "thisNode" : true , "hostname" : "10.143.200.101" },{ "services" :{ "mgmt" : 8091 , "mgmtSSL" : 18091 , "indexAdmin" : 9100 , "indexScan" : 9101 , "indexHttp" : 9102 , "indexStreamInit" : 9103 , "indexStreamCatchup" : 9104 , "indexStreamMaint" : 9105 , "indexHttps" : 19102 , "kv" : 11210 , "kvSSL" : 11207 , "capi" : 8092 , "capiSSL" : 18092 , "projector" : 9999 , "projector" : 9999 , "n1ql" : 8093 , "n1qlSSL" : 18093 }, "hostname" : "10.143.200.102" },{ "services" :{ "mgmt" : 8091 , "mgmtSSL" : 18091 , "indexAdmin" : 9100 , "indexScan" : 9101 , "indexHttp" : 9102 , "indexStreamInit" : 9103 , "indexStreamCatchup" : 9104 , "indexStreamMaint" : 9105 , "indexHttps" : 19102 , "kv" : 11210 , "kvSSL" : 11207 , "capi" : 8092 , "capiSSL" : 18092 , "projector" : 9999 , "projector" : 9999 , "n1ql" : 8093 , "n1qlSSL" : 18093 }, "hostname" : "10.143.200.103" }], "clusterCapabilitiesVer" :[ 1 , 0 ], "clusterCapabilities" :{ "n1ql" :[ "enhancedPreparedStatements" ]}}

          People

            jmorris Jeff Morris
            matthew.groves Matthew Groves
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty