Uploaded image for project: 'Couchbase .NET client library'
  1. Couchbase .NET client library
  2. NCBC-2851

TimeoutExceptions continue after rebound in Failover/Eject tests

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.0.7
    • 3.2.5
    • library
    • None
    • 1

    Description

      In some of the Failover/Eject tests the results show latency starting in the change phase (possibly expected), but after the rebound phase it does not recover. Further looking into logs, TimeoutExceptions are seen happening until the end of the test, which likely the cause of the latency.

      This has yet to be replicated in a non-situational/jenkins environment, but specific tests (FoEptEject-HYBRID/FoEptRb-HYBRID, etc) have been failing for some time (at least 3.0.7).

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jmorris Jeff Morris added a comment - This appears to be fixed as of 3.2.5 (and possibly before): http://sdkqe-testresults.couchbase.com.s3.amazonaws.com/SDK-SDK/CB-7.0.2-6698/FoEptRb-HYBRID/12-09-21/002445/e25ff23f5ff738cb7d2b96b3cbebdd62-MC.html http://sdkqe-testresults.couchbase.com.s3.amazonaws.com/SDK-SDK/CB-7.0.2-6698/FoEptEject-HYBRID/12-09-21/001943/af94fe6e383fb00186a543f99b573dce-MC.html

          People

            jmorris Jeff Morris
            jmorris Jeff Morris
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty