Uploaded image for project: 'Couchbase Python Client Library'
  1. Couchbase Python Client Library
  2. PYCBC-1219

Correct preserve_expiry N1QL test

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 3.2.6
    • None
    • None
    • 1

    Description

      change self.MIN_VERSION to 7.1 otherwise SkipTest() will fail (only happens when testing on server versions < 7.1)

          def test_preserve_expiry(self):
              version = self.cluster.get_server_version()
              if version.short_version < 7.1:
                  raise SkipTest("QueryOptions.preserve expiry only available on server versions >= {}".format(
                      self.MIN_VERSION))
      

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          jared.casey Jared Casey added a comment - - edited

          SkipTest() message corrected to use 7.1 instead of self.MIN_VERSION

          jared.casey Jared Casey added a comment - - edited SkipTest() message corrected to use 7.1 instead of self.MIN_VERSION

          People

            jared.casey Jared Casey
            jared.casey Jared Casey
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty