Uploaded image for project: 'Couchbase Python Client Library'
  1. Couchbase Python Client Library
  2. PYCBC-455

Test/fix compilation on MacOS High Sierra

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major
    • Resolution: Cannot Reproduce
    • 2.3.2
    • 2.3.4
    • library
    • None

    Description

      A customer was having trouble linking Couchbase Python Client on MacOS High Sierra - see the forum thread here:

      https://forums.couchbase.com/t/sdk-compilation-issue-on-high-sierra/15053

      This ostensibly seems to relate to the renaming of the CoreTLS library, and creating a symlink functions as a workaround. However, Sierra has already moved CoreTLS, so either there is some transitional code in Sierra which isn't in High Sierra, or something needs to be added to libcouchbase/couchbase-python-client to handle the name change.

      We should attempt to reproduce this on High Sierra, and issue a fix/solution.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          Ellis.Breen Ellis Breen added a comment -

          Have upgraded Sierra machine to High Sierra and am unable to reproduce the issue, yet.

          Ellis.Breen Ellis Breen added a comment - Have upgraded Sierra machine to High Sierra and am unable to reproduce the issue, yet.
          Ellis.Breen Ellis Breen added a comment - - edited

          Asked user if they have come across the issue since, but apparently it has only occurred on their one machine. Will suspend this issue as "Cannot Reproduce" for now.

          Ellis.Breen Ellis Breen added a comment - - edited Asked user if they have come across the issue since, but apparently it has only occurred on their one machine. Will suspend this issue as "Cannot Reproduce" for now.
          Ellis.Breen Ellis Breen added a comment - https://forums.couchbase.com/t/sdk-compilation-issue-on-high-sierra/15053/13

          People

            Ellis.Breen Ellis Breen
            Ellis.Breen Ellis Breen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty