Uploaded image for project: 'Couchbase Python Client Library'
  1. Couchbase Python Client Library
  2. PYCBC-875

ViewQuery segfaults in bindings

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Cannot Reproduce
    • 3.0.0-beta.3
    • 3.0.0
    • None
    • None
    • SDK15: Ruby/Coll/Docs

    Description

      Seems we don't test it. So – fix it, test it, and test the ViewManager as well, which oddly has no tests (in v3 at least).

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          david.kelly David Kelly added a comment -

          Actually, I now cannot reproduce this. I changed something, rebuild, and it stopped. Then I reverted what I changed, rebuild again and it still didn't reproduce.

          Then I wiped things, build again, still good.

          So now, just adding the tests we already should have had.

          david.kelly David Kelly added a comment - Actually, I now cannot reproduce this. I changed something, rebuild, and it stopped. Then I reverted what I changed, rebuild again and it still didn't reproduce. Then I wiped things, build again, still good. So now, just adding the tests we already should have had.
          david.kelly David Kelly added a comment -

          this isn't reproducing any more, closing. Opening new ticket for view tests.

          david.kelly David Kelly added a comment - this isn't reproducing any more, closing. Opening new ticket for view tests.

          People

            david.kelly David Kelly
            david.kelly David Kelly
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty