Uploaded image for project: 'Couchbase Python Client Library'
  1. Couchbase Python Client Library
  2. PYCBC-915

Remove support for Python <3.5

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 3.0.0
    • 3.0.4
    • None
    • None
    • 1
    • SDK30: Connect,Txns

    Description

      Lets have setup.py insist on a minimum version of 3.5 for python, and clean up any < 3.5 stuff we have in there, and elsewhere.  Maybe the enum34?  Possibly others?

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          Ellis.Breen Ellis Breen added a comment - - edited

          This change should already have mandated Python>=3.5:

          http://review.couchbase.org/c/couchbase-python-client/+/126528/6/setup.py

          But we should also remove <Python3.5 legacy dependencies.

          Ellis.Breen Ellis Breen added a comment - - edited This change should already have mandated Python>=3.5: http://review.couchbase.org/c/couchbase-python-client/+/126528/6/setup.py But we should also remove <Python3.5 legacy dependencies.

          People

            Ellis.Breen Ellis Breen
            david.kelly David Kelly
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes

                PagerDuty