Uploaded image for project: 'Couchbase Server'
  1. Couchbase Server
  2. MB-4862

upgrading a 1.8.1 couchbase server ubuntu installation might fail to upgrade/migrate the data due to missing openssl dependency

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: build, installer
    • Security Level: Public
    • Labels:
      None

      Description

      Most Linux distros have moved on to OpenSSL 1.0 and later versions. Couchbase Server (the ├╝berpackage) is still linking against a very old OpenSSL, and thus even our latest 2.0 builds don't work against year-old Linux distros out of the box. This will be a bigger problem in April, when Ubuntu Oneric ships and doesn't even have 0.9.8 in it's distro. I know it won't be supported, but developers will try to use it and be cut off from Couchbase Server if we don't resolve the issue.

      From the bug reporter:
      $ sudo dpkg -i couchbase-server-community_x86_64_2.0.0-dev-preview-3.deb
      Selecting previously unselected package couchbase-server.
      (Reading database ... 394120 files and directories currently installed.)
      Unpacking couchbase-server (from
      couchbase-server-community_x86_64_2.0.0-dev-preview-3.deb) ...
      dpkg: dependency problems prevent configuration of couchbase-server:
      couchbase-server depends on libssl0.9.8 (>= 0.9.8f-5); however:
      Package libssl0.9.8 is not installed.
      dpkg: error processing couchbase-server (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      couchbase-server

      Ubuntu Natty (11.10) also have openssl 0.9.8
      http://packages.ubuntu.com/natty/utils/openssl

      But next version which is coming soon (Ubuntu Oneiric 12.04) as like
      Debian unstable already use 1.0.0e
      http://packages.ubuntu.com/oneiric/openssl

      Generally it isn't a problem now, but in the April

      See also MB-4497, where the decision at the time was won't fix.

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Hide
        pavelpaulau Pavel Paulau added a comment -

        Notice that installer warns users about dependency issue only in case of upgrade.

        Otherwise users still get all these unclear errors.

        Show
        pavelpaulau Pavel Paulau added a comment - Notice that installer warns users about dependency issue only in case of upgrade. Otherwise users still get all these unclear errors.
        Hide
        mccouch MC Brown (Inactive) added a comment -

        What needs to be documented here?

        Are we going to recommend users install openssl 0.9.8 when the installation says it is required?

        MC

        Show
        mccouch MC Brown (Inactive) added a comment - What needs to be documented here? Are we going to recommend users install openssl 0.9.8 when the installation says it is required? MC
        Hide
        farshid Farshid Ghods (Inactive) added a comment -

        yes.

        also for users who are trying to install 2.0 for the first time we need to have this in documentation and the website as well

        http://www.couchbase.com/issues/browse/MB-6971

        Show
        farshid Farshid Ghods (Inactive) added a comment - yes. also for users who are trying to install 2.0 for the first time we need to have this in documentation and the website as well http://www.couchbase.com/issues/browse/MB-6971
        Hide
        bcui Bin Cui (Inactive) added a comment -

        When installer detects that libssl0.9.8 doesn't exist during fresh installation or upgrade, it will stop installation and give instructions to install the missing libssl0.9.8. And it will be helpful to put it as a prerequisite for ubuntu 12.0 setup.

        Show
        bcui Bin Cui (Inactive) added a comment - When installer detects that libssl0.9.8 doesn't exist during fresh installation or upgrade, it will stop installation and give instructions to install the missing libssl0.9.8. And it will be helpful to put it as a prerequisite for ubuntu 12.0 setup.
        Hide
        andreibaranouski Andrei Baranouski added a comment -

        should user restart manually server after upgrade was stopped?

        ubuntu@ip-10-39-13-185:/tmp$ sudo dpkg -i couchbase-server-community_x86_64_2.0.0-1971-rel.deb
        (Reading database ... 31678 files and directories currently installed.)
        Preparing to replace couchbase-server 1.8.1 (using couchbase-server-community_x86_64_2.0.0-1971-rel.deb) ...

        =INFO REPORT==== 3-Dec-2012::15:56:42 ===
        Initiated server shutdown** at node ns_1@127.0.0.1 **

        =INFO REPORT==== 3-Dec-2012::15:56:48 ===
        Stopped ns_server application** at node ns_1@127.0.0.1 **

        • Stopped couchbase-server
          No packages found matching libssl0.9.8.
          Installing cannot proceed since the package 'libssl0.9.8' is missing.
          Please install libssl0.9.8 and try again.

        $sudo apt-get install libssl0.9.8

        You can also restart couchbase as follows:

        $sudo /etc/init.d/couchbase-server start

        dpkg: error processing couchbase-server-community_x86_64_2.0.0-1971-rel.deb (--install):
        subprocess new pre-installation script returned error exit status 1
        Errors were encountered while processing:
        couchbase-server-community_x86_64_2.0.0-1971-rel.deb
        ubuntu@ip-10-39-13-185:/tmp$ ps -ef| grep couchbase
        ubuntu 3687 3502 0 16:41 pts/1 00:00:00 grep --color=auto couchbase
        ubuntu@ip-10-39-13-185:/tmp$ ^C
        ubuntu@ip-10-39-13-185:/tmp$ sudo /etc/init.d/couchbase-server start

        • Started couchbase-server
        Show
        andreibaranouski Andrei Baranouski added a comment - should user restart manually server after upgrade was stopped? ubuntu@ip-10-39-13-185:/tmp$ sudo dpkg -i couchbase-server-community_x86_64_2.0.0-1971-rel.deb (Reading database ... 31678 files and directories currently installed.) Preparing to replace couchbase-server 1.8.1 (using couchbase-server-community_x86_64_2.0.0-1971-rel.deb) ... =INFO REPORT==== 3-Dec-2012::15:56:42 === Initiated server shutdown** at node ns_1@127.0.0.1 ** =INFO REPORT==== 3-Dec-2012::15:56:48 === Stopped ns_server application** at node ns_1@127.0.0.1 ** Stopped couchbase-server No packages found matching libssl0.9.8. Installing cannot proceed since the package 'libssl0.9.8' is missing. Please install libssl0.9.8 and try again. $sudo apt-get install libssl0.9.8 You can also restart couchbase as follows: $sudo /etc/init.d/couchbase-server start dpkg: error processing couchbase-server-community_x86_64_2.0.0-1971-rel.deb (--install): subprocess new pre-installation script returned error exit status 1 Errors were encountered while processing: couchbase-server-community_x86_64_2.0.0-1971-rel.deb ubuntu@ip-10-39-13-185:/tmp$ ps -ef| grep couchbase ubuntu 3687 3502 0 16:41 pts/1 00:00:00 grep --color=auto couchbase ubuntu@ip-10-39-13-185:/tmp$ ^C ubuntu@ip-10-39-13-185:/tmp$ sudo /etc/init.d/couchbase-server start Started couchbase-server

          People

          • Assignee:
            bcui Bin Cui (Inactive)
            Reporter:
            ingenthr Matt Ingenthron
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes