Most Linux distros have moved on to OpenSSL 1.0 and later versions. Couchbase Server (the überpackage) is still linking against a very old OpenSSL, and thus even our latest 2.0 builds don't work against year-old Linux distros out of the box. This will be a bigger problem in April, when Ubuntu Oneric ships and doesn't even have 0.9.8 in it's distro. I know it won't be supported, but developers will try to use it and be cut off from Couchbase Server if we don't resolve the issue.
From the bug reporter:
$ sudo dpkg -i couchbase-server-community_x86_64_2.0.0-dev-preview-3.deb
Selecting previously unselected package couchbase-server.
(Reading database ... 394120 files and directories currently installed.)
Unpacking couchbase-server (from
dpkg: dependency problems prevent configuration of couchbase-server:
couchbase-server depends on libssl0.9.8 (>= 0.9.8f-5); however:
Package libssl0.9.8 is not installed.
dpkg: error processing couchbase-server (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
Ubuntu Natty (11.10) also have openssl 0.9.8
But next version which is coming soon (Ubuntu Oneiric 12.04) as like
Debian unstable already use 1.0.0e
Generally it isn't a problem now, but in the April
MB-4497, where the decision at the time was won't fix.